Issue 106710 - slide corrupted in slideshow mode when custom animation used
Summary: slide corrupted in slideshow mode when custom animation used
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: viewing (show other issues)
Version: OOO320m4
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: wolframgarten
QA Contact: issues@graphics
URL:
Keywords: regression
: 106721 (view as issue list)
Depends on:
Blocks: 99999
  Show dependency tree
 
Reported: 2009-11-08 12:44 UTC by jbf.faure
Modified: 2017-05-20 10:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
bugdoc, does not work well in slideshow mode (18.03 KB, application/vnd.oasis.opendocument.presentation)
2009-11-08 12:45 UTC, jbf.faure
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jbf.faure 2009-11-08 12:44:37 UTC
Version : OOO320_m4 under Ubuntu 8.04.
Please, open the bugdoc and launch the slideshow. Lines are incomplete and some
texts are hidden. If you remove all custom animations slideshow is correct.

The same file opened with OOo 3.1.1 works fine.
The defect is also confirmed under XP.

Regards
JBF
Comment 1 jbf.faure 2009-11-08 12:45:37 UTC
Created attachment 66005 [details]
bugdoc, does not work well in slideshow mode
Comment 2 wolframgarten 2009-11-09 08:07:19 UTC
Reproducible. Reassigned.
Comment 3 Olaf Felka 2009-11-09 10:29:16 UTC
Accepted as 3.2 stopper.
Comment 4 groucho266 2009-11-16 09:50:50 UTC
Sorry for the delay, I was on vacation.

I can reproduce this paint error on Windows XP, both with and without hardware
acceleration.
Comment 5 groucho266 2009-11-16 10:20:46 UTC
*** Issue 106721 has been marked as a duplicate of this issue. ***
Comment 6 groucho266 2009-11-16 10:23:22 UTC
This paint error is caused by an optimization regarding clipping, made by me :(
Have to find the exact place though.
Comment 7 groucho266 2009-11-17 12:34:05 UTC
The ImplRegionBand copy constructor did not copy its mpFirstBandPoint member
correctly.

Fixed that in SVN revision 277533.
Comment 8 groucho266 2009-11-19 14:30:55 UTC
@wg: Please verify.
Comment 9 wolframgarten 2009-11-20 08:55:34 UTC
Verified in CWS.