Issue 106749 - WW8: new page style via table format not exported
Summary: WW8: new page style via table format not exported
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOO310m19
Hardware: All All
: P3 Trivial (vote)
Target Milestone: 3.4.0
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: regression
Depends on: 117121
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-09 23:35 UTC by jameskuyper
Modified: 2017-05-20 10:30 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
This is the original file (72.00 KB, application/msword)
2009-11-09 23:36 UTC, jameskuyper
no flags Details
This is the file after I used "Save As" with no changes. (37.00 KB, application/msword)
2009-11-09 23:37 UTC, jameskuyper
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jameskuyper 2009-11-09 23:35:20 UTC
I had a problem with a MS Word file whose contents changed spontaneously when I
saved it. I eventually verified that the change occurs even if I don't make any
changes of my own. I opened the original file which was three pages long. The
following titles appeared at the top of each page:

"Sigma Space Performance Goals and Results (Page 1)"
"Sigma Space Performance Assessment (Page 2)"
"Sigma Space Performance Goals: Next Year (Page 3)"

Without making any changes whatsoever, I selected "File/Save As" and gave it a
new name. The usual window popped-up saying that the file was in Microsoft Word
97/2000/XP format, and asking if I was sure I wanted to save it in the same
format. I selected "Keep Format". When I opened up the file with new name, it's
contents had changed. It now had four pages titled:

"Sigma Space Performance Goals and Results (Page 1)"
"Raytheon Performance Screen                    Company Most Private"
"Sigma Space Performance Goals and Results (Page 1)"
"Raytheon Performance Screen                    Company Most Private"

The pages of the new file that have headers referring to Raytheon also have
footers saying:
"HR-PD-2
Revised 01/09/01  SAS:dtl"

The contents of the first three pages were unchanged; the new fourth page was
empty except for the headers and footers described above.
Comment 1 jameskuyper 2009-11-09 23:36:23 UTC
Created attachment 66025 [details]
This is the original file
Comment 2 jameskuyper 2009-11-09 23:37:22 UTC
Created attachment 66026 [details]
This is the file after I used "Save As" with no changes.
Comment 3 michael.ruess 2009-11-10 11:21:49 UTC
MRU->HBRINKM: problem is, that the new page style (Convert1) which is set via
the table format on page 2 will not be exported to WW8 format. Also the style
"Convert1" will not be exported at all an cannot be set manually after reload of
the document. Thus the header layout will be screwed up.
Broke in OOo 3.0.1.
Comment 4 jameskuyper 2009-11-10 18:37:17 UTC
There's really two problems here: an OpenOffice problem which hbrinkm has
identified, and the fact that the original file contains some text that it
shouldn't. I'd appreciate help with that second problem, too, though it's not
strictly an OpenOffice one.

Looking at the original file using OpenOffice, by selecting Format/Styles and
Formatting, and then selecting the "Page Styles", I see that pages 1 and 3 use
the style "Default", while page 2 uses the style "Convert1". By left-clicking on
those styles and selecting modify, I can verify that the relevant difference is
that Convert1 has "Same content left/right", turned on, while Default does not.

To cope with this problem, our SA has installed Wine and Microsoft Word on my
machine. Could you tell me how to find the corresponding information while using
Microsoft Word? The closest I've figured out is going to the "Page Layout" Tab
and selecting the arrow icon on the lower right corner of the Page Setup
section. On all three pages, "Different even and odd" is selected in the
"Headers and Footers" section.

Using Microsoft Word, by selecting the Home tab and then 'Find' in the "Editing"
section, I get a pop-up dialog. If I type in "Raytheon", click on "Find in" and
select "Headers and Footers" from the drop-down menu, the window splits, and the
bottom portion is titled "Even Page Header" containing the Raytheon page
heading. A similar search for "HR-PD-2" puts the "Even Page Footer" in that
bottom window.

Can you tell me how I could display the same things in OpenOffice?
Thanks!
Comment 5 openoffice 2011-02-28 14:33:12 UTC
Analysis: There is a section break in the original file at the end of page 1 that does not get imported.
Comment 6 openoffice 2011-03-01 09:34:52 UTC
Analysis: Not inserting a section is correct, because wwSectionManager::InsertSegments inserts a page description instead.
Comment 7 openoffice 2011-03-01 17:04:24 UTC
fixed:
changeset: a9c1cec88310

@mst: Please verify.
Comment 8 michael.ruess 2011-03-14 15:14:53 UTC
Verified in CWS sw34bf04.