Issue 106824 - Writer crashes when Bibliography database is opened
Summary: Writer crashes when Bibliography database is opened
Status: CLOSED DUPLICATE of issue 105408
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 3.1.1
Hardware: PC Windows 7
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-11 16:01 UTC by jovancormac
Modified: 2009-12-04 15:06 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jovancormac 2009-11-11 16:01:17 UTC
Did a clean install of OpenOffice 3.1.1 with Writer, Calc and Impress (German
Version) on Windows 7 Home Premium.

Simply opening Writer and clicking on the menu item Tools->Literature database
(Extras->Literaturdatenbank in German) crashes the program with a Windows system
error.

Since this is my first bug report to OO.org and I don't know the ropes around
here, I have left the default priority setting (P3) intact, but obviously this
warrants immediate attention so P5 would probably more appropriate.

Regards,
Jovan
Comment 1 michael.ruess 2009-11-11 16:10:35 UTC
Cannot confirm that with 3.1.1 on Windows 7, the Bibliography database starts
properly. Did you change any options in the default installation settings?
Comment 2 jovancormac 2009-11-11 16:24:05 UTC
No, no changes. As I said, clean install, no configuration at all.

Always reproducible on my system. Happens whether or not I have a document opened.
Comment 3 michael.ruess 2009-11-12 08:40:11 UTC
Did you send a crash report? I mean, did the crash report front end appear after
OOo crashed?
If not, it might be a corrupted installation...
If you sent a report via the front end, should should have received a Main from
SUN giving an ID. Please post it here. Thanks!
Comment 4 jovancormac 2009-11-12 12:25:52 UTC
The crash report front end didn't show up.

What it says is this:

"Runtime Error!

Program: C:\Program Files (x86)\OpenOffice.org 3\program\soffice.bin

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information."
Comment 5 eric.savary 2009-11-12 12:32:28 UTC
" C:\Program Files (x86)\..."

@MRU: Related to the also not reproducible issue 100458? 64bit Win7?
Comment 6 michael.ruess 2009-11-12 12:46:57 UTC
Program: C:\Program Files (x86) ...

You run OOo on Windows7-64bit? I tried on 32bit.
Comment 7 jovancormac 2009-11-12 12:53:55 UTC
That's right, it's 64bit Win7. Unfortunately, the issue reporting form doesn't
have an option for indicating that platform.
Comment 8 jovancormac 2009-11-12 12:56:18 UTC
@es: It's probably the very same issue. I did a search before posting, but that
one didn't come up. I can therefore CONFIRM that issue, and the other one should
probably be reopened/merged into this one.
Comment 9 michael.ruess 2009-11-12 13:05:56 UTC
MRU->OS: it looks, that the Biblio crashes on Windows7-64bit. Do we have a
chance to debug this?
Comment 10 michael.ruess 2009-11-16 15:58:52 UTC
I now checked wth the newest OOO320m4 build on a 64bit Win7 but got no crash.

MRU->jovancormac: could you please check with the newest OOo 3.2 dev build if
the problem still occurs on your system? Thanks for supporting us!
Comment 11 jovancormac 2009-11-16 16:51:17 UTC
I downloaded and installed OOo-dev 3.2 with the same options I had used before
(just Writer, Impress, Calc, default additional components) and it crashes just
the same when I try to open the Bib db. This time I used the U.S. version to
rule out the language issue but that doesn't appear to be it either.
Comment 12 michael.ruess 2009-11-17 11:22:08 UTC
Does it help when you delete the OpenOffice configuration in c:\document and
settings ?
Comment 13 jovancormac 2009-11-19 13:12:03 UTC
No, it doesn't.
Comment 14 stefan.baltzer 2009-12-02 11:52:11 UTC
Another colleague (JA) could not find problems on his Windows 7 64bit machine.
So Windows 7, 64bit is not the core problem, only "a hint".

Now the trouble begins to circle this in.
If this happens only on your machine, there is "something" different from the
Win7 64bit machines that others used. Big wonder, as all Machines come with
different features (hardware) that can not be installed or emulated elsewhere.

Installing a debug environment on your machine to see what goes wrong looks a
bit off scope here :-)

As a guess (experience from the past), the graphic hardware or its driver
version COULD be to blame. Or some graphic accelerator settings of it. Or the
combination. Or... something completely different :-(

Does Win7 have something like a "secure boot mode" like the older ones have?
That could be worth a try. In such a modus, all graphic-related gizzmos among
other tools are OFF and do not interfere. If THAT helps in your case, you "just"
have to figure out the difference between normal and secure boot.

Some questions into the blue:
Can you open the dialog "Insert-Indexes and Tables - Indexes and Tables"?
Does <F4> work in Writer? (shows current database)
Does "Edit - Exchange database" work?
Do you have other dialogs or Wizards that crash?
What Java version(s) does the office use? (see Tools - Options - OOo - Java)
Comment 15 jovancormac 2009-12-02 12:03:42 UTC
"Installing a debug environment on your machine to see what goes wrong looks a
bit off scope here :-)"

Why not? I'm a professional software developer myself, though I mostly code in
PHP. Can you give me instructions or a link that tells me how to set up an
appropriate environment (Java I presume)? OpenOffice.org has given me a lot and
I am more than willing to go the distance in order to help fix this important bug.
Comment 16 stefan.baltzer 2009-12-03 17:49:51 UTC
Oh. I am surprised. Well, I am not a developer myself, but I know that it is
mainly written in C++. So you will need a Visual C++ Studio installation.
Then you will need "the pdb files" (debug-built libraries, we have them here and
could put them somewhere on an ftp account to avoid you building an office from
scratch yourself). And then you need assistance for the details. Therefore I put
MBA on c/c.

SBA-> Jovancormac: In what time zone are you? (Whould a live chat possible?)
Comment 17 jovancormac 2009-12-03 18:10:44 UTC
@SBA/MBA: Will VS Express suffice? I'm surprised OOo isn't built using free
software. But the VC++ debugger is certainly good, and if OOo can be built with
Express, I'll gladly do it. My time zone is GMT+1, I have time for a live chat
(and to build+debug) on Sunday, Dec 6th. Just tell me where you want to meet
(IRC preferably).
Comment 18 Mathias_Bauer 2009-12-04 09:01:39 UTC
Yes, the Express Edition will suffice.

wrt. the free software tooling: if you want to build an application on Windows
that integrates with the system and its libraries and works efficiently, there's
no real alternative to Visual Studio. Thanks to the Express version it's at
least possible to build and develop OOo without paying for the compiler, even if
it's not "free".

IRC is fine, we can start at #dev.openoffice.org on Freenode. I will prepare a
pdb file download. For which version shall I do this?

After reading the previous comments I have a question: did you deselect
components on installation? Can you reproduce the crash with a default installation?
Comment 19 jovancormac 2009-12-04 11:08:04 UTC
IMPORTANT UPDATE: mba, your idea was spot on. The components selected during
installation do indeed matter!

I have found the following to be the case:

Install OOo-Dev_OOO320_m4_Win32Intel_install_en-US using a "Complete"
installation: NO CRASH
Install OOo-Dev_OOO320_m4_Win32Intel_install_en-US using a "Custom"
installation, deselecting Draw, Base and Math (as I had done): CRASH!

So I ran a few experiments and finally narrowed it down to the "Base" component
alone. Install with Base, everything works, install without Base, Writer crashes
when opening Bibliography db.
Comment 20 michael.ruess 2009-12-04 11:43:17 UTC
Ah, so it sounds like duplicate of issue 105408... does anyone agree?
Comment 21 Oliver Specht 2009-12-04 11:51:07 UTC
aggreed

*** This issue has been marked as a duplicate of 105408 ***
Comment 22 michael.ruess 2009-12-04 12:02:35 UTC
Closing duplicate.
Comment 23 jovancormac 2009-12-04 12:10:11 UTC
Then Issue 100458 (which was closed as WORKSFORME) is probably a duplicate of
that same issue as well.
Comment 24 Mathias_Bauer 2009-12-04 15:06:23 UTC
Indeed.
Thanks for working with us to find the root cause.