Issue 106863 - Spotlight search in native file picker freezes OOo
Summary: Spotlight search in native file picker freezes OOo
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOO320m4
Hardware: Mac Mac OS X, all
: P2 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: thorsten.martens
QA Contact: issues@framework
Depends on:
Blocks: 99999
  Show dependency tree
Reported: 2009-11-12 18:24 UTC by Uwe Altmann
Modified: 2017-05-20 10:29 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Uwe Altmann 2009-11-12 18:24:00 UTC
Menu "File" > Open
Put something into spotlight search field (upper right corner of the
file picker window)
select a OOo-file from search result and click "open" to open it.

The file will not be opened and OOo kind of freezes - i.e. selecting a
menu entry works (menus open etc.) but nothing happens when a menu
command is selected.

"Quit" after a few minutes brings up the beachball cursor and then
crashes into Document Recovery where it gets stuck ,sometimes doing the actions (i.e. openíng a new 
document or command window) which have been requested after freeze.
Comment 1 mdxonefour 2009-11-13 10:25:59 UTC
MD: I tried this with a OOO320m4 on Snow Leopard and can confirm the described

Additional I tried a OOo 3.1.1 on the same machine. The behavior with that
version is little different, but also not ok.
- Menu "File->Open"
- Search via Spotlight in file open and select an ODF file to open
--> crash
Unfortunatly no crash reporter shows up. Some times the document recovery comes
up one time and you are back at work and some times the document recovery loops.
(See also Issue 106292)

So it seems we already had a spotlight/file open/search issue in 3.1.1.
Comment 2 mdxonefour 2009-11-13 10:41:21 UTC
MD Same behavior as described for OOo 3.1.1 can be found when using OOo 3.0.1.
(checked on Snow Leopard)
Comment 3 thorsten.martens 2009-11-16 09:21:25 UTC
TM->PL: please have a look.
Comment 4 Olaf Felka 2009-11-16 13:58:08 UTC
Comment 5 Olaf Felka 2009-11-16 13:58:38 UTC
Comment 6 philipp.lohmann 2009-11-17 10:34:58 UTC
Comment 7 philipp.lohmann 2009-11-17 10:49:12 UTC
fixed in CWS ooo32gsl06
Comment 8 philipp.lohmann 2009-11-18 10:24:53 UTC
please verify in CWS ooo32gsl06
Comment 9 michael.ruess 2009-11-20 13:56:46 UTC
Verified fix in CWS 00032gsl06.