Issue 10709 - problems adding tables to a query
Summary: problems adding tables to a query
Status: CLOSED DUPLICATE of issue 8949
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: PC Windows 2000
: P2 Trivial (vote)
Target Milestone: ---
Assignee: Frank Schönheit
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-01-16 17:34 UTC by Unknown
Modified: 2006-05-31 14:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-01-16 17:34:25 UTC
Hi guys,

I created two simple (2 and 3 lines) tables into two separate sheets in an 
OpenOffice spreadsheet.  Then, I selected Tools->Data Sources->New Data Source, 
collect data from SPREADSHEET, then tried to create a query.

The query only allows me to add ONE table, not both.

The online docs imply it's possible to add multiple tables.  Spent about 1/2 
hour trying to get around the problem.

The tables were something like this (just very simple, trying to link by CODE):

[sheet Orders]
Name     Code   Order    
Linus    998    flashlight
Mike     134    quake III
Mary     574    shoes


[sheet Addresses]
Code   Address
998    Milky Way
574    Pluto

Thanks,

Mike Darrett
Comment 1 Frank Schönheit 2003-01-17 09:22:31 UTC
Mike, thanks for supporting OOo.

This Calc driver currently does not support cross-table queries, thus
is is no defect, but a missing feature. We already have a feature
request for cross-table queries for dBase data sources, and because
the engine for both dBase and Calc are the same internally, I mark
this bug here is duplicate of the RFE.

*** This issue has been marked as a duplicate of 8949 ***
Comment 2 Frank Schönheit 2003-01-17 09:22:58 UTC
closing duplicate
Comment 3 hans_werner67 2004-02-02 12:57:21 UTC
change subcomponent to 'none'