Issue 107235 - Other applications crashes when OpenOffice is installed (Column handler shell extention)
Summary: Other applications crashes when OpenOffice is installed (Column handler shell...
Status: CLOSED DUPLICATE of issue 102757
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 3.1.1
Hardware: Unknown Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks:
 
Reported: 2009-11-26 15:00 UTC by holmfred
Modified: 2010-03-11 21:23 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description holmfred 2009-11-26 15:00:40 UTC
When an application that open or saves text files with the standard open file
dialogue in Windows, the applications crashes without prompting a
send-this-bug-to-Microsoft dialogue when opening or saving a file. One example
of a such a program is Notepad from Microsoft. This only happens when OpenOffice
is installed. 


The error can be produced in this way:
* Start Notepad from the Windows Start-menu. (Start -> Run ... -> notepad)
* Open the open file dialogue "File -> Open ...".
* Make sure that the Desktop is shown and put the mouse over an existing text
file or folder but do not click. Just hold the mouse still and wait for the info
square to pop up. (There must already exist a text file or a folder on the
desktop. A shortcut to a file or folder do not produce this error.)
* Press "Cancel" to close the open file dialogue.
* Open the open file dialogue one more time "File -> Open ...".
* Make sure that the Desktop is shown and put the mouse over an existing text
file again and wait for the info square to pop up.
* Now the application crashes before the info square pops up.


Some comments.
* the error can only be produces when the a file or folder is on the desktop. 
* If the "OpenOffice.org Column Handler" is disabled, the error cannot be
reproduced. The Column Handler extention can be disabled with a software called
"ShellExView" from "NirSoft". (Link to software:
http://www.nirsoft.net/utils/shexview.zip)
Comment 1 Rainer Bielefeld 2009-11-26 15:25:06 UTC
I can reproduce the crash with Notepad (not with Editpad Light, not with MS WORD
Viewer), but currently I will not uninstall my Ooo 3.1.1 WIN XP DE-multilingual
version German UI activated [OOO310m19 (Build 9420)]" and  "Ooo-Dev 3.2.0
multilingual version English UI WIN XP: [DEV300m64 (Build 9446)]" to check
whether really OOo is the reason for those crashes.

@holmfred:
What other applications did you see crashing?
How did you figure out that OOo is the reason?
Comment 2 holmfred 2009-11-26 16:43:03 UTC
I noticed a difference between computers that had this crash and computer that
did not had this crash, and that was OpenOffice. If I uninstalled OpenOffice the
crash could not be reproduced.

But you do not have to uninstall OpenOffice to see that the crash can be
avoided. If you run the program "ShellExView", as I linked in the last post, an
disable the "OpenOffice.org Column Handler", the crash can not be reproduced.

I think that the open file dialogue (or save file dialogue) must include a
filter of *.txt files. So far I have only found Notepad but you can also get the
crash from a simple program that calls "getOpenFile()" and filter out *.txt files.
Comment 3 leo_davidson 2009-12-17 12:14:00 UTC
Another report of the OpenOffice.org Column Handler crashing 3rd party apps (in
this case Directory Opus, a file manager, when any of the handler's columns are
enabled in a folder with one or more files):

http://resource.dopus.com/viewtopic.php?p=59081#59081

Crash reportedly went away when the OOo handler was disabled.
Comment 4 lohmaier 2010-03-11 21:23:21 UTC
same description as issue 102757 → flagging duplicate.

*** This issue has been marked as a duplicate of 102757 ***
Comment 5 lohmaier 2010-03-11 21:23:46 UTC
closing duplicate.