Issue 107278 - Resample mode for improved view of downscaled jpg images required
Summary: Resample mode for improved view of downscaled jpg images required
Status: CLOSED DUPLICATE of issue 46535
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 3.1.1
Hardware: Other Windows, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: Armin Le Grand
QA Contact: issues@gsl
URL:
Keywords: oooqa
Depends on:
Blocks: 46535
  Show dependency tree
 
Reported: 2009-11-27 23:12 UTC by lenlyon
Modified: 2009-12-10 21:13 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The failing JPG file (673.29 KB, text/plain)
2009-11-27 23:19 UTC, lenlyon
no flags Details
Bad OOW Document (729.88 KB, text/plain)
2009-11-28 17:00 UTC, lenlyon
no flags Details
Print Screen of the Problem (captured in a WORD document) (285.00 KB, text/plain)
2009-11-28 17:02 UTC, lenlyon
no flags Details
Corresponding WORD document with no problem (698.50 KB, text/plain)
2009-11-28 17:02 UTC, lenlyon
no flags Details
Corresponding WORD document with no problem (698.50 KB, text/plain)
2009-11-28 17:03 UTC, lenlyon
no flags Details
Compares various screenshots, view with or without resampling (421.83 KB, application/pdf)
2009-11-28 17:57 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lenlyon 2009-11-27 23:12:34 UTC
Platform/OS: Windows 7RC on Dell Inspiron 1720  (laptop)
             Windows XP  on Dell Dimemsion 2400 (desktop)
  
When I insert a particular JPG file into my OO Writer document, 
black "shingles" or "checker board squares" are added. I would attach the JPG 
file to this submission, but I don't see how to do it.
Comment 1 lenlyon 2009-11-27 23:17:05 UTC
OS/Platform = Windows 7RC     on Dell Inspiron  1720 (laptop)
              Windows XP Home on Dell Dimension 2400 (desktop)
   
When I insert a particular JPG file in my writer document, black "shingles" 
or "checkerboard squares" are added to the picture.
Comment 2 lenlyon 2009-11-27 23:19:40 UTC
Created attachment 66382 [details]
The failing JPG file
Comment 3 Rainer Bielefeld 2009-11-28 09:37:20 UTC
NOT reproducible with "Ooo 3.1.1 WIN XP DE-multilingual version German UI
activated [OOO310m19 (Build 9420)]"!

@lenlyon:
Please 
- Attach 
 -- Writer document with inserted picture
  -- Screenshot showing "shingles" or "checker board squares"
- contribute 
  -- Information 
    --- concerning your graphic cards
    --- whether that problem also appears with CALC, DRAW, IMPRESS
  -- a step by step instruction containing all observations (error
     messages ...), _every_key_press_and_every_mouse_click_ how to 
     reproduce the problem
Comment 4 lenlyon 2009-11-28 17:00:43 UTC
Created attachment 66384 [details]
Bad OOW Document
Comment 5 lenlyon 2009-11-28 17:02:06 UTC
Created attachment 66385 [details]
Print Screen of the Problem (captured in a WORD document)
Comment 6 lenlyon 2009-11-28 17:02:52 UTC
Created attachment 66386 [details]
Corresponding WORD document with no problem
Comment 7 lenlyon 2009-11-28 17:03:00 UTC
Created attachment 66387 [details]
Corresponding WORD document with no problem
Comment 8 lenlyon 2009-11-28 17:15:39 UTC
I just discovered that the problem does not occur in a single column ducument. 
It does in a two column document.
   
I've attached three files per your request. The last got in twice, but I don't 
know how to remove the duplicate.
   
My DELL 2400 Display adapter is reported as ..
Intel(R) 82845G/GL/GE/PE/GV Graphics Controller
  
If you really need it, I'll dig out thet info for my DELL Inspiron 1720.
  
I don't use CALC, DRAW, IMPRESS. I'm just starting out using WRITER to decide 
whether or not to use it to replace WORD when I get my new systems in the 
spring.
   
I get no error messages.
   
If you still cannot see the problem given the new attachments, I will describe 
step by step how I created the problem, but it's straight forward. The overview 
is ..
  Open WRITER
  Specify 2 columns
  Provide a little text
  Insert the photo
Comment 9 Rainer Bielefeld 2009-11-28 17:49:36 UTC
Reproducible with "Ooo 3.1.1 WIN XP DE-multilingual version German UI activated
[OOO310m19 (Build 9420)]"!

The problem has to do with size of the image. When you reduce size (to width
80mm), it looks ugly with many in OOo and fine in WORD. 
In printout and PDF-export the problem disappears (more or less), I would say
for me the print looks a little better from OOo than from WORD viewer (with my
OJ6100).

I also see that problem with particular jpg images from particular digi-cams -
mine - for example :-(

These images need some special "Resampling" to be shown correctly in erduced
size, please see my attachment "ShowResampeEffec" from IfanView!

Attached P1010052.JPG also looks ugly (shingle lines) with seamonky if size of
image view will be resized, and also in IV without resample mode, as you see in
my screenshots.

Same viewing problem in DRAW, so -> gsl

Works as designed, so ENHANCEMENT (or Feature?)
Comment 10 Rainer Bielefeld 2009-11-28 17:56:02 UTC
Might be required for all OS?
Comment 11 Rainer Bielefeld 2009-11-28 17:57:09 UTC
Created attachment 66389 [details]
Compares various screenshots, view with or without resampling
Comment 12 Regina Henschel 2009-11-28 19:48:38 UTC
Seems to be a similar problem as issue 46535.
Comment 13 philipp.lohmann 2009-12-01 17:58:18 UTC
That would be more of a drawinglayer issue
Comment 14 Armin Le Grand 2009-12-04 11:52:48 UTC
AW: Indeed the same as #i46535#, the moire effect is the result of a not
filtered downscale. Also necessary info: Images in SW and in Draw/Impress/Calc
are two pair of shoes (SW uses it's own objects for it), but i checked and both
seem to use the same paint mechanism, so i think slideshow will do the same.

Drawinglayer has three mechanisms for Bitmap paint:

(1) The edit view uses GraphicObject::Draw(...) from the GraphicManager stuff.
It is also prepared to use 
(2) OutputDevice::DrawBitmapEx(...) and 
(3) an own downscaler (RenderBitmapPrimitive2D_self).

Please refer to VclProcessor2D::RenderBitmapPrimitive2D to see the possibilities
of drawinglayer. The usage depends on transformation information, e.g (1) works
with rotation, but not with shear, (2) is neither able to use rotation nor
shear, and (3) was needed when shear is used (no other solution offered until then).
Comment 15 Armin Le Grand 2009-12-04 11:53:33 UTC
AW. Setting to double

*** This issue has been marked as a duplicate of 46535 ***
Comment 16 Mechtilde 2009-12-10 21:13:37 UTC
duplicate -> closed