Issue 107331 - [CWS printerpullpages] Show actual paper size near preview
Summary: [CWS printerpullpages] Show actual paper size near preview
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: printing (show other issues)
Version: DEV300m61
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: 3.4.0
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-30 18:39 UTC by Regina Henschel
Modified: 2012-05-10 23:35 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2009-11-30 18:39:22 UTC
If the user prints objects, which have set unusual size in the page layout, the
paper sheet size, which the printer uses (set by OOo?) might be very surprising.
I'll list some examples from my printer HP Color LaserJet on WinXP. It is a
typical small business printer, which has a tray for DinA4 and a single sheet feed.
1. 
Writer document with page A3 portrait.
Printer uses A4 with additional setting "Fit to Page".
The user can only notice, that he has used a wrong page size, if he notices in
the preview, that the text lines are to long.
2.
Writer document with page width=10,5cm height=7,4cm (=DinA7), landscape
Printer uses "Letter", although my local is "Germany".
The user cannot see in the preview, that it is "Letter", because the preview is
to small to show the difference.
3.
Writer document with page width=20cm height=10cm, landscape
Printer uses "Umschlag Monarch" (Umschlag=envelope) with width 190mm, height 98mm
The user expects, that a supported format is used, that is large enough to
contain the whole page. The preview is to small to show that 1cm are missing.

For a better solution have a look at the Acrobat Reader printing dialog:
* It shows the actual page size as measure lines at the edges of the preview.
* It shoes the paper sheet in gray in the preview and therein the document page
in white.
* It shows both paper sheet size and document page size as text beneath the preview.

There is enough place above the preview to show at least the paper sheet size.
(Paper sheet size is the more important information, because the user should
know the page size of his document, but does not know, which paper sheet size is
set.)

Please add such information. Currently I _always_ have to enter the properties
to make sure the paper size is set correctly.
Comment 1 michael.ruess 2009-12-01 15:39:05 UTC
Reassigned to PL for evaluation of technical practicability.
Comment 2 philipp.lohmann 2009-12-01 17:06:24 UTC
there is no question about the feasibility; just tell me where to put it. In the
debug version the page format already comes up as a tooltip.
Comment 3 Regina Henschel 2009-12-02 00:03:08 UTC
Please see two proposals on
http://wiki.services.openoffice.org/wiki/Printerpullpages/Idea_Collection
Comment 4 christoph 2009-12-03 23:54:49 UTC
Hi Regina, hi Philipp!

My initial impressions:
* I don't really get the point :-)
* I had a look at the Adobe Acrobat and I think that it is a rather technical
dialog and requires much space...
* Showing the size does only help if people use the same settings throughout the
whole document, otherwise they have to scan all pages manually. That doesn't
help them.
* The real sizes are not that helpful (e.g. when showing them besides the
document page) if people are unable to judge the sizes. How many people do
really know the size (+/- 2 cm) of DIN ISO A4? 5%? Less? :-)
* How does it relate to the size settings in Draw/Impress? It seems that those
settings already address some of the issues page vs. page setting.

However, just to get the point...
If the page size settings from the printer differ from the page settings of the
document, then user wishes that the system prevents wrong printout.

Some questions with regard to the problems:
1) Where do you set "Fit to Page"? Is that a printer setting?

2) Why does that happen? Why does your printer use "Letter"?

3) When does that happen? I'm sorry, I don't get the point why different
settings are manually entered by the user. At least it seems so.

I have some additional idea in mind how to solve that. But first I would like to
better understand that - even on UX discuss if it seems better suited. But,
thank you very much Regina for your ideas and mockups. It's so easy to ask /
criticize, because you already provided so much material. Thanks!
Comment 5 christoph 2009-12-06 19:47:57 UTC
Hi all! I've added two more proposals on the already introduced wiki page.
Again, the link for your convenience:
http://wiki.services.openoffice.org/wiki/Printerpullpages/Idea_Collection
Comment 6 Regina Henschel 2009-12-06 22:49:56 UTC
Both suggestions are suitable for the purpose and better than my suggestions.

@christophnoack
->1) Yes "Fit to page" is a setting in my printer properties. I had not set it
manually, but it was set without my knowing. I do not know, whether OOo sets it.
->2) I do not know, where the setting "letter" comes from. I had not set it
manually.
->3) The point is, that the user sets a page size in Format > Page and do not
use printer properties at all. The printer uses some paper sheet size
automatically (I don't know from where) and the user does not know this size
unless he looks into the printer properties. The problems occur for me when not
using standard A4 in page size, but other formats like envelopes or user defined
formats.
Comment 7 christoph 2009-12-07 22:09:11 UTC
@Regina: As always I'm quite happy with your great explanations. But, I don't
know whether the new proposals are better. I had a look at Gnome and they do
have less space restrictions and a second tab (for special settings and thus
more experienced users): they use a proposal similar to your first one. 

Besides that I like the idea (especially the re-usable message area approach),
the main problem seems to be the weird behavior of the printer driver. Maybe we
should have a look at the OOo-PrinterDriver-communication first. What do you think?

@PL: Do you have any experience / knowledge how printer drivers pick settings
based on document settings?
Comment 8 philipp.lohmann 2009-12-08 09:37:39 UTC
Printer drivers do pretty much as they wish, so if we don't request a specific
paper size, they'll do whatever they see fit.
Comment 9 philipp.lohmann 2010-02-12 13:21:18 UTC
feature freeze for 3.3 draws close now. If there is no final spec soon, this
will have to wait for a later release.
Comment 10 christoph 2010-02-15 22:57:55 UTC
christophnoack --> PL: Sorry, I wasn't aware of that you are waiting for a spec.
When is the deadline for a rather complete spec for 3.3? I'm asking because some
of the CC topics compete with printing at the moment... Thank you & bye! Christoph
Comment 11 philipp.lohmann 2010-02-16 08:23:02 UTC
For coding I don't need a full spec, but I'd need some consensus how this should
look like - at the moment I don't know that. Feature freeze is middle of march
(I could be more precise if the wiki release pages would load), at which point
this would have to have passed QA and be integrated. However this is a not a
mission critical feature, so I have no problem with delaying this change to 3.4
if there are more pressing concerns.
Comment 12 Regina Henschel 2010-02-25 21:41:18 UTC
I have added a comment to
http://wiki.services.openoffice.org/wiki/Printerpullpages/Idea_Collection with a
string proposal.

"if there are more pressing concerns": yes, there are i105299, i105067 and i105434.
Comment 13 philipp.lohmann 2010-05-06 14:07:22 UTC
We could still do something for 3.3. here; only we'd have to define what. From
the discussion in the wiki link I think we agree on the "little yellow" alert
kind of window. We'd just need the details fixed:

- will this be a yellow window always or (preferably) painted the same way a
tool tip would (making this matching the theme) ? In the latter case you would
possibly get a border around the window (depending on the theme). 
- what would be the text ? I'd vote for "The paper format <A4> (<210mm x 297mm>)
is not available. Paper <Letter> (<275mm x 279mm>) will be used" where of course
the things in <> will be replaced by actual values.
- someone would have to paint the image if there was to be one, once normal and
once in high contrast black mode.
Comment 14 Regina Henschel 2010-05-06 14:47:44 UTC
regina -->PL: The issue is not about "not available", but about the fact, that
OOo actually assumes the size of the sheet of paper for its printing
calculations, but the user does not know, what size is assumed. Therefore simple
write it in the kind of

Assumed size of sheet of paper (height x width)
210 mm x 297 mm = DIN A4

as my last comment of 25 February 2010 (UTC) in
http://wiki.services.openoffice.org/wiki/Printerpullpages/Idea_Collection

Best for me would be a fixed place. It is no alert, but an information that
should be always visible.

If OOo assumes a size of the sheet of paper depending on the actual document
part, the values should correspond to the document part shown in the preview,
and change, when moving the preview to another part of the document.
Comment 15 philipp.lohmann 2010-05-06 15:41:15 UTC
So there is no consensus after all. Ok.
Comment 16 philipp.lohmann 2010-10-12 16:05:17 UTC
Implemented regina's sample; left and above the print preview now the paper
dimensions of the "assumed" paper (that which the printer driver tells us) are shown

fixed in CWS vcl116
Comment 17 philipp.lohmann 2010-10-26 17:17:23 UTC
please verify in CWS vcl116
Comment 18 h.ilter 2010-11-02 11:56:28 UTC
Verified with vcl116 = ok
Comment 19 Regina Henschel 2012-05-10 23:35:29 UTC
See the paper size in AOO3.4