Issue 107439 - Excel export: External references bloat the exported file
Summary: Excel export: External references bloat the exported file
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: save-export (show other issues)
Version: OOo 3.1.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords:
: 104483 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-12-04 09:53 UTC by daniel.rentz
Modified: 2017-05-20 11:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description daniel.rentz 2009-12-04 09:53:04 UTC
When using external references in formulas, the exported XLS file may become way
too big.
Comment 1 daniel.rentz 2009-12-04 10:05:21 UTC
started
Comment 2 daniel.rentz 2009-12-15 14:38:28 UTC
Reasons:
- The same external cached values are written out for every formula using them
(and not just once).
- Cached values are written out for all empty cells in the external target
document (they can be simply left out).
Comment 3 daniel.rentz 2009-12-15 17:12:37 UTC
fixed in CWS DEV300/dr75 (OOo 3.3)
Comment 4 daniel.rentz 2010-01-28 17:07:16 UTC
back to QA
Comment 5 kla 2010-03-10 13:25:03 UTC
Seen ok in cws dr 75 -> verified
Comment 6 niklas.nebel 2010-05-25 16:31:02 UTC
*** Issue 104483 has been marked as a duplicate of this issue. ***