Issue 107443 - When copying table columns, a default value is entered
Summary: When copying table columns, a default value is entered
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 3.1
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Reported: 2009-12-04 13:09 UTC by windl
Modified: 2017-05-20 10:47 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

example database (6.99 KB, application/vnd.sun.xml.base)
2009-12-07 08:02 UTC, r4zoli
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description windl 2009-12-04 13:09:40 UTC
When copying DATE columns from one table to another (using Copy and Paste), the
inserted column definition has a default value, even if the original column that
was copied had none. This is an undesired change of content between copy and paste.
(Found in StarOffice 9.1 on Windows/XP SP3)
Comment 1 r4zoli 2009-12-05 12:22:19 UTC
Please describe your problems more elaborated, step-by-step.
Under what OS that happens?
You tried on other versions of OOo?

Follow the issue tracker rules:

Upload an example file where you find this copy-paste issue, without sensitive data.
Comment 2 windl 2009-12-07 07:21:17 UTC
The OS was Windows/XP. I have a database with multiple tables. Some table
columns (i.e. entity types) are present in many tables (e.g. valid_from,
valid_until). So I thought it would save me time to copy and paste those common
Procedure: Mark the desired entities in the table design, then copy them. Switch
to the target table and paste them. Now in the target table the new date
entities have a default value like "01.01.1980", while the original entities do
not have them. I have not tried other versions of OOo.
Comment 3 r4zoli 2009-12-07 08:01:06 UTC
I tested in OOO320_m7, on winXP, Hungarian local settings, the default value
which was inserted: 1901-01-01, same as you can find in "Format example" field,
below the "Default value" in table design view. 
May be the value depend on local settings.

I created example file, the date field was copied from Table1 to Table2.

You can remove the default value in design view, and save table design. 
Comment 4 r4zoli 2009-12-07 08:02:03 UTC
Created attachment 66530 [details]
example database
Comment 5 Frank Schönheit 2009-12-07 09:18:47 UTC
confirming, targeting, grabbing
Comment 6 windl 2009-12-07 12:06:26 UTC
I had made a mistake: The default is actually "01.01.01" (as indicated). Yes, I
found out the work-around, but I thought I'll report it, because you'll have to
be careful not to overlook that new default. Also, other data types (like
INTEGER) also get a default value (0 in the case of INTEGER).
Comment 7 Marcus 2017-05-20 10:47:29 UTC
Reset assigne to the default "".