Issue 107525 - file locking broken
Summary: file locking broken
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOO320m7
Hardware: Unknown Windows XP
: P2 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks: 99999
  Show dependency tree
 
Reported: 2009-12-08 10:11 UTC by cno
Modified: 2017-05-20 10:29 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description cno 2009-12-08 10:11:14 UTC
- open /create file in m7
- edit
- now go to FileManager and cut/paste the file to another location
 > is allowed
 > should be blocked
- when saving the file in OOo a message about "changes made since ..  " appears.
Comment 1 mikhail.voytenko 2009-12-08 11:04:13 UTC
Thank you for the issue. Good that it was found early enough to be fixed in OOo3.2.

As for the dialog "changes made since ..  ", it is correct here. The file was
indeed changed, from other side the text could be probably explain the situation
better.

Investigating the original problem.
Comment 2 cno 2009-12-08 11:24:33 UTC
@mav:

> Thank you for the issue. Good that it was found early enough to 
> be fixed in OOo3.2."

You're welcome. Our pleasure that it will be fixed. Hopefully before RC1..

> As for the dialog "changes made since ..  ", it is correct here. The 
> file was indeed changed, from other side the text could be probably 
> explain the situation better."

Yes, but not really needed if the problem is fixed ;-)
Comment 3 mikhail.voytenko 2009-12-09 21:04:57 UTC
Should be fixed in cws jl146 now.
Comment 4 mikhail.voytenko 2009-12-11 09:20:38 UTC
mav->tm: Please verify the issue.
Comment 5 thorsten.martens 2009-12-11 13:44:19 UTC
Problem is fixed for existing documents but occurs still for new ones.
Comment 6 thorsten.martens 2009-12-11 13:45:12 UTC
reassigned
Comment 7 mikhail.voytenko 2009-12-11 14:03:42 UTC
Yes, indeed, sorry for inconvenience, I had to test the scenario as well.
Should be fixed now.
Comment 8 mikhail.voytenko 2009-12-11 14:39:13 UTC
mav->tm: Please verify the issue.
Comment 9 thorsten.martens 2009-12-14 09:27:25 UTC
checked and verified in cws jl146 -> OK !