Issue 107552 - vcl: crash parsing (broken) Aquabase-spanish-support.ttf
Summary: vcl: crash parsing (broken) Aquabase-spanish-support.ttf
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOO320m6
Hardware: All Unix, all
: P3 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: hdu@apache.org
QA Contact: issues@gsl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-09 10:22 UTC by caolanm
Modified: 2010-02-04 10:09 UTC (History)
2 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
avoid crashing with that font (1.45 KB, patch)
2009-12-09 10:22 UTC, caolanm
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description caolanm 2009-12-09 10:22:03 UTC
Aquabase-spanish-support.ttf can be found in a fonts.tar.gz subpackage inside
https://sourceforge.net/projects/mac4lin/files/

Sticking this in ~/.fonts and launching OOo should crash (and will show valgrind
errors). Attached is a patch to avoid crashing

https://bugzilla.redhat.com/show_bug.cgi?id=544218 and
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/365763
are the real-world report of this
Comment 1 caolanm 2009-12-09 10:22:47 UTC
Created attachment 66564 [details]
avoid crashing with that font
Comment 2 hdu@apache.org 2009-12-09 12:23:22 UTC
Applied in CWS vcl108. Thanks Caolan!
Comment 3 hdu@apache.org 2010-01-06 15:10:36 UTC
@es: please verify in CWS vcl108
Comment 4 eric.savary 2010-01-21 14:27:34 UTC
@HDU: cannot reproduce in the master. Please check this.
Comment 5 hdu@apache.org 2010-01-21 14:29:49 UTC
.
Comment 6 caolanm 2010-02-04 10:09:10 UTC
integrated m71