Issue 107794 - MySQL tables accessed via ODBC do not display in Base
Summary: MySQL tables accessed via ODBC do not display in Base
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 3.2 RC1
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords: oooqa, regression
: 107764 (view as issue list)
Depends on:
Blocks: 99999
  Show dependency tree
 
Reported: 2009-12-20 15:40 UTC by john.mccreesh
Modified: 2010-01-13 23:44 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Screenshot showing problem with tables (39.29 KB, image/png)
2009-12-20 15:41 UTC, john.mccreesh
no flags Details
Screenshot showing queries are ok (50.37 KB, image/png)
2009-12-20 15:42 UTC, john.mccreesh
no flags Details
Sample database which displays this problem (851 bytes, text/plain)
2009-12-20 15:43 UTC, john.mccreesh
no flags Details
patch (3.53 KB, patch)
2010-01-06 11:47 UTC, ocke.janssen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description john.mccreesh 2009-12-20 15:40:41 UTC
Symptoms: Base connects successfully to MySQL tables via ODBC. However, all the
table names and contents are blank. Queries display OK.

I will attach screenshots and a test database which displays this condition. The
odbc.ini entry is:

[MySQL-stuff]
Driver		=	MySQL
Server		=	localhost
Database	=	stuff
User		=	mystuff
Password	=	stuffy
Port		=	3306
Comment 1 john.mccreesh 2009-12-20 15:41:29 UTC
Created attachment 66728 [details]
Screenshot showing problem with tables
Comment 2 john.mccreesh 2009-12-20 15:42:02 UTC
Created attachment 66729 [details]
Screenshot showing queries are ok
Comment 3 john.mccreesh 2009-12-20 15:43:27 UTC
Created attachment 66731 [details]
Sample database which displays this problem
Comment 4 john.mccreesh 2009-12-20 15:44:19 UTC
*** Issue 107764 has been marked as a duplicate of this issue. ***
Comment 5 Mechtilde 2009-12-21 09:15:21 UTC
IMO it isn't a stopper because ODBC is one of tree possibilities to work with MySQL

@ jpmcc
Which distri do you use?

Which packages for ODBC did you install?

Did you also try the nativ mysql connector?
Comment 6 john.mccreesh 2009-12-21 10:03:29 UTC
From the OOo-Dev Database Wizard:
Connect to an existing database -> MySQL -> Next
Connect using ODBC -> Next
Browse for the ODBC data source -> Next
Test Connection -> "Connection established successfully" -> OK -> Next
Do not register the database -> Open the database for editing -> Finish

This is on a current Ubuntu 'Karmic Koala' system, unixodbc 2.2.11-16ubuntu1,
mysql-server 5.1.37-1ubuntu5
Comment 7 Mechtilde 2009-12-21 10:13:29 UTC
IMO it isn't a stopper because ODBC is one of tree possibilities to work with MySQL

@ jpmcc
Which distri do you use?

Which packages for ODBC did you install?

Did you also try the nativ mysql connector?
Comment 8 Mechtilde 2009-12-21 10:17:24 UTC
1. there is the installation of libmyodbc missing
2. the nativ mysql connector is an extension and can be installed with the
Extension Manager
3. at http://de.openoffice.org/doc/oooauthors/odbc-datenbanken-verbinden.pdf

you find a German description how to configure the ODBC-Connection to a
mysql-Server.
Comment 9 john.mccreesh 2009-12-21 10:18:36 UTC
I've now installed mysql-connector-ooo-1.0.0-linux-intel.oxt and when I attempt
'Test Connection' I get 

SQL Status: HY000
Error code: 2002
Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

However, I don't believe extensions were ever intended as a mechanism for
providing a workround for broken code in the core product..
Comment 10 john.mccreesh 2009-12-21 10:21:15 UTC
libmyodbc is 3.51.19r646-1

This works ok in OOo 3.1, so I think my ODBC setup is ok :-)
Comment 11 Mechtilde 2009-12-21 10:33:31 UTC
yes there is a error message if you try to connect to localhost but it works
nevertheless.

and I will test an ODBC connection again and report 
Comment 12 john.mccreesh 2009-12-21 12:02:05 UTC
I can confirm that the native connector does work if you ignore the error
message and continue. However, I would expect users to give up if 'Test
Connection' returns an error...
Comment 13 Mechtilde 2009-12-21 13:40:22 UTC
yes the problem with "Test connection" is a know problem. As I know it is fixed
by fs.

It only appears if you connect to localhost.
Comment 14 john.mccreesh 2009-12-21 16:05:23 UTC
This problem also affects MySQL tables used as data sources in Calc
Comment 15 drewjensen.inbox 2009-12-21 17:00:10 UTC
Trying Ubuntu 9.10 (644bit) here:

ODBC connection is broken here also, as described in the issue. No table names
in any GUI view.

I can not reproduce any of the problems with the Native Connector and sockets,
seems to work for me. (but that isn't this issue, right)

Comment 16 drewjensen.inbox 2009-12-21 17:25:49 UTC
Just a slight different check - instead of selecting MySQL->ODBC for the data
source I tried the other way ODBC->MySQL and the Base (OO.o) UI acts slightly
different.

With MySQL->ODBC the table items are listed with icons, so the user can see that
some number of tables exists, just can't see the names.

Using ODBC->MySQL the table section of the Base window (or any wizards that
display table objects) is completely blank. No icons with empty names, so the
user doesn't even see that there are any tables there at all.
Comment 17 drewjensen.inbox 2009-12-21 18:27:40 UTC
Ok tested both scenarios (Mysql->ODBC, ODBC->MySQL) under 3.1.1 in the exact
environment as that for 3.2m_7 - no problems in Base or Calc.

Adding keyword regression
Assigning to developer
Comment 18 Raphael Bircher 2009-12-21 23:04:12 UTC
.
Comment 19 ocke.janssen 2010-01-05 07:58:31 UTC
Fixed in cws dba32k
Comment 20 ocke.janssen 2010-01-06 07:06:39 UTC
Please verify in cws dba32k. Thanks.
Comment 21 ocke.janssen 2010-01-06 11:47:35 UTC
Created attachment 67026 [details]
patch
Comment 22 Frank Schönheit 2010-01-06 13:38:42 UTC
patch looks good (as far as I can judge this, with my somewhat limited expertise
in this particular area)
Comment 23 marc.neumann 2010-01-06 14:28:54 UTC
verified in CWS dba32k

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba32k
Comment 24 drewjensen.inbox 2010-01-13 23:44:41 UTC
Checked w/ XP, OOO320_RC2, MySQL ODBC Connector 5.1 (with and without the Sun 
MySQL native connector 1.0.0 installed)

Closing