Issue 107865 - local linked sections should update automatically
Summary: local linked sections should update automatically
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOO310m11
Hardware: All All
: P3 Normal with 1 vote (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-23 23:10 UTC by unordained
Modified: 2014-04-24 15:38 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---


Attachments
two tables, in sections, one is a linked version of the other (8.91 KB, application/vnd.oasis.opendocument.text)
2010-01-04 15:24 UTC, unordained
no flags Details
links inside the document should be updated without any question (10.01 KB, application/vnd.oasis.opendocument.text)
2014-04-24 15:38 UTC, mroe
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description unordained 2009-12-23 23:10:18 UTC
I see the reasoning behind "update all links" happening only when opening the
document, or upon user request, when the linked content is in another file.

But if you need a section to appear in two places in the same document, one
editable and one read-only, it sure would be nice if editing one immediately
updated the other.

The "update all links" option isn't visible by default; if users are opening a
document, fixing up something wrong in the first section, they're not going to
realize that to get the second section to update, they have to either enable a
menu item (painful) and use it every time they make a change, or save, close and
re-open the document.

In this scenario immediate auto-update seems quite preferable -- it's likely to
happen anyway next time the document's opened. This isn't an issue of wanting to
preserve an old version of that same section elsewhere in the document. In my
case, it's a legal document, and the two copies MUST match exactly.

I found some reports of sections auto-updating themselves when going to print
the document, but that didn't seem to be the case for me.

As a sidenote, I've found that openoffice knows that a blank xlink:href in the
text:section-source tag means "self", there doesn't have to be a file name when
you create a linked section (the ODF spec says the field is implied, but doesn't
speak to this point.) I appreciate this, because I'm generating documents via
XSL, and I'd prefer not to have to know the document's final file name for the
sections I'm embedding in it to be able to refer to the current document itself.
Comment 1 eric.savary 2009-12-31 13:28:05 UTC
Please attach a sample document
Comment 2 eric.savary 2010-01-04 14:56:06 UTC
Feel free to reopen when you'll have the information needed.
Comment 3 eric.savary 2010-01-04 14:56:21 UTC
closed
Comment 4 unordained 2010-01-04 15:24:55 UTC
Created attachment 66973 [details]
two tables, in sections, one is a linked version of the other
Comment 5 unordained 2010-01-04 15:26:40 UTC
Added example document. To test: just edit anything in the first table. Your 
changes won't be reflected in the second until you update all links, or close 
and reopen the document, despite it being a locally-linked section (no other 
users are going to be editing it, we don't need to poll the filesystem for 
changes, etc.)
Comment 6 eric.savary 2010-01-04 15:38:24 UTC
Reassigned
Comment 7 Rob Weir 2013-02-02 02:56:27 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 8 Edwin Sharp 2014-04-02 19:25:23 UTC
Confirmed with
AOO410m14(Build:9760)  -  Rev. 1582709
2014-03-30_04:11:07 - Rev. 1583103
Debian
Comment 9 mroe 2014-04-24 15:38:30 UTC
Created attachment 83270 [details]
links inside the document should be updated without any question

I stumbled about this issue by creating a template for a letter.
Please have a look at the attached document.

At the first page there is a frame that should hold the data of the sender (contact, bank etc.).
Because the rest of the document is designed with an other page layout (other page template) the data should be gotten from the first page. If there is a change of the data needed they have to be only changed on the first page.

But if the user opens the file or create a new letter based on the template he is always ask to update the links ...

It isn't possible to change the link so it is updated automatically.