Issue 107882 - Ability to send mail merge emails for particular documents lost
Summary: Ability to send mail merge emails for particular documents lost
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 3.2 RC1
Hardware: PC Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact:
Keywords: crash, regression
Depends on: 108081
  Show dependency tree
Reported: 2009-12-24 21:20 UTC by Rainer Bielefeld
Modified: 2017-05-20 10:13 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Here the test stopped because of crash (before step 1 ... (87.52 KB, image/png)
2010-01-13 18:37 UTC, Rainer Bielefeld
no flags Details
Test document (pls. see comments from rainerbielefeld Sun Jan 17 17:49:11 +0000 2010 ) (21.05 KB, application/vnd.oasis.opendocument.text)
2010-01-17 17:57 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Rainer Bielefeld 2009-12-24 21:20:37 UTC
With installation of a.m. Version my OOo lost ability to send mail merge emails
lost from my SMTP account. All required functions (address database ...) work if
they are used separately, even connection to mail server works fine, when I
tested. But when I went step by step through the wizard and reach the step "send
documents", the progress dialog opened, but not document has been sent. I
canceled the attempt after 15 minutes. A second attempt also failed, but now I
was not able to cancel, I had to abort OOo with WIN task manager.
From then on I have been no longer able to use mail merge Wizard, OOo hangs as
soon as I try to start. Repair of OOo installation did not help, also deletion
of my user profile did not heal the problem.
Comment 1 Rainer Bielefeld 2009-12-25 07:47:18 UTC
If that can be confirmed, it would be a blocker for 3.2
Comment 2 Rainer Bielefeld 2009-12-25 09:29:30 UTC
A complete uninstallation, new installation after registry cleanup has healed
the hang-problem, but 3.2 still does not send mail merge emails.
Comment 3 cno 2009-12-26 22:18:11 UTC
Hi Rainer,
just installed 3.2.0rc1 on Ubuntu
(did parallel installation, but pointed to the 3.1.1 user data for the user

Fist trial gave the same problem: did not work
then I merged to single files and immediately afterwards tried send via mail again.
This time it worked (as you will have seen in your mail box).

Will test again in the next days ..
Comment 4 cno 2009-12-27 14:03:56 UTC
Hi again,
Installed rc1 on my old XP, replacing 3.1.1
Could email mail merge without problem ...
Comment 5 Rainer Bielefeld 2009-12-27 17:55:44 UTC
Today it also worked for me. Repared? Good luck?

Thank you for your tests.
Comment 6 uwe.luebbers 2009-12-28 10:54:46 UTC
Seems it works, removed issue from meta issue and set to "invalid"
Comment 7 Rainer Bielefeld 2009-12-28 11:50:19 UTC
This issue is definitively not INVALID.
Comment 8 eric.savary 2010-01-04 15:48:48 UTC
rainerbielefeld: you wrote: "Today it also worked for me"
So we can close (whatever INVALID, WFM...) or do you still have this problem?
Comment 9 Rainer Bielefeld 2010-01-04 16:05:06 UTC
I think it's too early to close this issue - what do you believe how many users
already have done that mail merge test with the RC?
But I'm just downgrading to 3.1.1. because of Issue 107967, and won't do any
further tests here.
Comment 10 eric.savary 2010-01-04 17:01:04 UTC
rainerbielefeld: you reported this issue. You are a QA member. You are the only
one (Cor didn't succeed) who can provide more information but you tell us you
won't do it... I see no point in keeping this issue alive.
Comment 11 cno 2010-01-04 20:02:54 UTC
@es: I hope there is no reason to keep it alive :-)
But note, that the first time I started mail merge, I did have the same problem.
So it might happen that others will stumble over it as well. Thus  at least we
must remember this one for some time ...
Comment 12 eric.savary 2010-01-04 20:53:20 UTC
@HI: can you please have a look at this?
Comment 13 eric.savary 2010-01-04 20:53:44 UTC
Comment 14 michael.ruess 2010-01-05 09:30:00 UTC
Sorry, but I am also not able to reproduce this with 3.2 RC (WinXP). eMailMerge
worked fine.
I can only imagine that this could be related to a special case...
Comment 15 h.ilter 2010-01-05 13:27:21 UTC
Take also a look to cws: pythonssldedux
Chould be interesting for you.
Comment 16 Rainer Bielefeld 2010-01-13 18:32:16 UTC
Still a problem with 3.2.0RC2, MMW doesn't even start, OOo hangs immediately
after MailMergeWizard has been started.
3.1.1 worked fine after I downgraded from RC1
Comment 17 Rainer Bielefeld 2010-01-13 18:37:23 UTC
Created attachment 67176 [details]
Here the test stopped because of crash (before step 1 ...
Comment 18 Rainer Bielefeld 2010-01-15 17:53:52 UTC
My suspect is that this one has the same roots like (NEW) Issue 107967, but
currently I do not have a test kit available.
Comment 19 Rainer Bielefeld 2010-01-15 17:56:13 UTC
Please excuse me for the SPAM, wrong issue!
Comment 20 cno 2010-01-16 17:18:08 UTC
Hi Rainer,
Just a minute ago a test-mail from my WinXP 320rc2 installation landed in your
mailbox. And just later a PDF version.
It was from a fresh installation, fresh user-data, first use of the mail merge
So there seems to be something in your situation that prevents it to work properly.
Comment 21 Rainer Bielefeld 2010-01-16 17:58:46 UTC
Definitively! Pls. see 108081 for other problems, currently unfortunately I
don't have enough time to create a test kit for this issue.
Comment 22 Rainer Bielefeld 2010-01-17 17:49:11 UTC
I was able to create a test kit that shows the problem 100% reproducible (on my PC)
For this please proceed as per comments from rainerbielefeld Fri Jan 15 13:24:48
+0000 2010 and with my test kit for Issue 108081, but use attached
"sampledoc107882.odt" instead of "testbrief_db5withoutlinkedcontents.odt"
Here OOo hangs immediately in step 5
Comment 23 Rainer Bielefeld 2010-01-17 17:57:34 UTC
Created attachment 67249 [details]
Test document (pls. see comments from rainerbielefeld Sun Jan 17 17:49:11 +0000 2010 )
Comment 24 Rainer Bielefeld 2010-01-17 18:11:35 UTC
And I found another strange fact.
When I started a document containing a macro from a "not reliable folder" (so
that I got a request "proceed?" from my macro security settings) and then
proceed the steps to reproduce the crash, everything will work fine, even the
crash from Issue 108081 will not appear.
Comment 25 Rainer Bielefeld 2010-01-17 18:53:31 UTC
I did 2 tests switching Macro Security down to Low and back to "Medium" (always
with reboot after modification) and for these tests it was reproducible:
- Security Low: no crash, MMW E-Mail works fine
- Security Medium: HANG, MMW hangs immediately after it has been started

I forgot to say: those hangs are without significant CPU load.
Comment 26 h.ilter 2010-01-18 13:22:44 UTC
@os: I did several tests with bugdoc and new docs but I can't reproduce it. 
I've also run all macro security levels, but it doesn't matter 
Please take a look for this special case. Thanks. 
Comment 27 Rainer Bielefeld 2010-01-18 17:20:36 UTC
Still reproducible with "Ooo 3.2.0 RC3 WIN XP DE-multilingual version German UI
activated [OOo320m10 (Build 9477)]", but I found 2 new effects:

I was not able to reproduce the relation to macro security settings, may be that
was a random effect with my rather few tests.
I see the crash opening the mail merge letter immediately after I started MMW,
but NOT, if I inserted any address data sett from data source browser (<f4>,
Data into Fields); after that proceeding MMW will work without any problem.

I don't believe any longer that this issue is related to Issue 108081
Comment 28 h.ilter 2010-03-26 12:22:51 UTC
Please test again with DEV300m71 or newer.
I've a good experience with and without SSL with that version on win7  
Comment 29 Rainer Bielefeld 2010-03-26 17:39:56 UTC
I need a DEV snapshot with fixed Issue 108081; latest tests still showed that
Comment 30 h.ilter 2010-06-24 14:41:42 UTC
Can we close this?
Comment 31 Rainer Bielefeld 2010-06-24 17:09:37 UTC
Still a problem  with "Ooo-Dev 3.3 multilingual version English UI WIN XP:
[DEV300m82 (Build 9510)]" although I renewed my user profile several times in
Comment 32 Rainer Bielefeld 2010-06-24 17:12:05 UTC
I see Issue 108081 is fixed for m83, I will check with that version.
Comment 33 Rainer Bielefeld 2010-06-25 15:23:49 UTC
Still same bad result with "Ooo-Dev 3.3 multilingual version English UI WIN XP:
[DEV300m83 (Build 9511)]". Sometimes OOo stops responding after menu 'Tools ->
Mail Merge Wizard' without any CPU load, sometimes I can proceed MMW. No Idea
how to make that 100% reproducible.
Comment 34 beppasverden 2010-10-15 06:42:16 UTC
Jeg ønsker å skrive en bok på Open Office og hvordan får jeg det til?
Comment 35 Rainer Bielefeld 2011-02-19 11:57:11 UTC
This is still a problem with 3.3.0. Everything works fine until I press "Send
Documents", then progress dialog starts, connection to mail send server will be
established, but no email will be sent, and after I while OOo will crash.

In between I have a new PC with WIN7 (and an old 3.1.1 to be able to use e-mail
mail merge).

I between I doubt that this problem is related to 108081.

I created a Crash Report with text "Crash report for Issue 107882" in it, I will
contribute a crash report ID asap.
Comment 36 Rainer Bielefeld 2014-03-12 13:21:40 UTC
No longer reproducible with server installation of "AOO 4.1.0-Beta – German UI / German locale - [AOO410m14(Build:9760)  -  Rev. 1573601 2014-03-03 17:47:48]" on German WIN7 Home Premium (64bit)", own separate user profile.

Probably you should tell what help you need.