Issue 107972 - Include an optional Auto-Save feature as an alternative to AutoRecovery.
Summary: Include an optional Auto-Save feature as an alternative to AutoRecovery.
Status: CLOSED DUPLICATE of issue 126869
Alias: None
Product: ui
Classification: Code
Component: ui (show other issues)
Version: OOO300m9
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-28 20:02 UTC by White Phoenix
Modified: 2017-05-20 09:26 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description White Phoenix 2009-12-28 20:02:04 UTC
See issue 97954

“Auto-Upgrade�

rainerbielefeld wrote:
If recovery fails, you still can hope that you will be able to open the old
document. And if not, because it has been damaged (may be because OOo crashed
just during an auto save), you would be thankful to have an additional AutoBackup.

Say that again? Are you for auto-backup or auto-restore? “If recovery fails, you
still can hope that you will be able to open the old document.†Yes, that is the
problem that we have been saying that an auto-save would solve.

“And if not, because it has been damaged (may be because OOo crashed just during
auto save), you would be thankful to have an additional AutoBackup.†My point is
that if it were being backed up as in the older word processors, Boxer Text
Editor, or the old Microsoft Works, the auto-recovery would be unnecessary. It
is one of the features of the newer versions of Word that I did not like and
made me look around for an alternative.

And, yes, I would be thankful that I had an additional AutoBackup on if the
auto-recovery failed. Which doesn’t happen because there is no auto-save. I have
never, in 30 years, had a program crash during an auto-save, but I have had
programs crash during an auto-recovery scan. Also, I have had corrupt
auto-recovery files, but never corrupt backup files.

I stated earlier that David Hamel, designer of Boxer, was able to have Boxer
undo even after an auto-save. And saving multiple copies of a file is not
necessary to do this. (Although you can save a copy of the file manually at any
time as “Copy of filename.extâ€.)

The other argument of hagar_de_lest is fixed by simply turning off or extending
the times between auto-saves (easy to do in Boxer) while you make your trial
edits. Boxer does not crash, by the way, but then it is only a simple text editor.

In any case, if you would rather let people have the option of either/or then do
that. I have done as you recommended and re-worded the request. As time goes on,
whenever people are given a choice the less popular (less reliable) feature
winds up being dropped. And to preempt the argument that people were given the
choice, no they were give a Hobson’s choice. Which gave them the impression that
companies like Microsoft did not care what they thought, so most of them just
accepted it as the way things are.
Comment 1 orcmid 2016-03-12 20:30:14 UTC
This request is relevant to the analysis on ways to mitigate/reduce/eliminate situations where documents are corrupted/lost by some misadventure.

Resolved as duplicate here is not to diminish the value of this request.  This the means we have for consolidation.

*** This issue has been marked as a duplicate of issue 126869 ***