Issue 107977 - Gray shadow suddenly turned black
Summary: Gray shadow suddenly turned black
Status: CLOSED DUPLICATE of issue 47519
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOO310m9
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2009-12-29 08:25 UTC by nyh
Modified: 2009-12-31 10:50 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Example odt with black text and black shadow (8.36 KB, application/vnd.oasis.opendocument.text)
2009-12-29 12:37 UTC, nyh
no flags Details
screenshot of hello.odt in OpenOffice on my computer (25.08 KB, image/png)
2009-12-29 12:37 UTC, nyh
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description nyh 2009-12-29 08:25:32 UTC
I am using OpenOffice from Fedora 12 (3.1.1, 310m19 build 94210).
I have a document where headers, in normal black fonts, had shadows. These
shadows always appeared gray. Now, suddenly, they became *black*, which looks
terrible - a black font with a black shadow just looks like really fat and ugly
black text.

I understand that currently I have no control over the shadow color, and some
automatic algorithm determines it. This is fine with me - it's just that
choosing a black shadow for a black font is wrong - the gray of the previous
OpenOffice releases was a reasonable choice.
Comment 1 Regina Henschel 2009-12-29 12:02:09 UTC
I cannot conform it for OOo3.2RC1. Are you sure the font color is really black?
Using other font colors than black results in black shadow, but using font color
black results in gray shadow.

Please verify that the problem is also in a OOo version from www.openoffice.org.
Otherwise report the problem to Fedora.
Comment 2 nyh 2009-12-29 12:37:01 UTC
Created attachment 66882 [details]
Example odt with black text and black shadow
Comment 3 nyh 2009-12-29 12:37:39 UTC
Created attachment 66883 [details]
screenshot of hello.odt in OpenOffice on my computer
Comment 4 nyh 2009-12-29 12:44:38 UTC
I just included two attachments - one is a fresh new document where I wrote the
word "Hello" in large font with a shadow, and the second is a screenshot, black
on black.

Anyway it turns out that your guess was right! When I carefully inspected the
screenshot, I noticed the text wasn't actually black, but rather dark gray! 
It turns out that when the "Font Color" is chosen to be "Automatic", while it
always used to be black - now it suddenly became dark gray. Is there any
explanation for this fact?

So now at least I know a workaround, but I wonder, why did suddenly "Automatic"
color become dark gray, instead of black? Like I said, this happened also to
files which I already had on my system, and were looking great on previous
OpenOffice versions.
Comment 5 eric.savary 2009-12-31 10:28:23 UTC
duplicate 

*** This issue has been marked as a duplicate of 47519 ***
Comment 6 eric.savary 2009-12-31 10:30:36 UTC
Closed
Comment 7 nyh 2009-12-31 10:50:29 UTC
Actually, this is not a duplicate... The problem is different, and regina put
the finger on it: It's that the default ("automatic") text color, which used to
be black is now dark gray, which is causing the shadow problem as a byproduct.

Maybe this bug should be closed and reopened with different text, but it's not a
duplicate of bug 47519.