Issue 108037 - Copy table wizard type formatting multiple selection broken
Summary: Copy table wizard type formatting multiple selection broken
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOO320m8
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords: oooqa, usability
Depends on:
Blocks:
 
Reported: 2010-01-02 21:13 UTC by azadian
Modified: 2017-05-20 10:23 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description azadian 2010-01-02 21:13:14 UTC
When doing the type formatting step in the import wizard, it is possible to
select multiple field names.  One then has the impression (hope) that setting
the column information will update all the selected fields.  Unfortunately, only
the first selected field is updated; the rest are silently ignored.

The easiest way to fix this would be to disable multiple selection.  This would
keep existing functionality and prevent the user from shooting himself in the
foot.  The preferred solution would be to do what the user obviously intends,
namely to update the column information for all of the selected field names.
Comment 1 r4zoli 2010-01-03 14:13:58 UTC
Changed  OS,summary, and issue type. 

It is more an enhancement not a defect.

The problem is still valid in OOo 3.2RC1, on linux.
Comment 2 r4zoli 2010-01-03 14:21:49 UTC
.
Comment 3 Frank Schönheit 2010-01-04 10:07:06 UTC
I'd agree to the original submitter that this is a DEFECT. A usual UI concept is
that actions done by the user apply to the selection, not only to a (not
noticeable) part of it.

Resetting issue type, adding "usability" keyword, assigning, confirming (as per
r4zoli's comment), targeting.
Comment 4 ocke.janssen 2010-01-07 11:38:47 UTC
We should define what should happen if

- the user changed a property like length for a db type where this setting isn't
valid
- the user tries to change the name

Or should we only allow to set the type? Or should we disable the column control
on the right side when selecting multiple columns. (By the way we can't make it
a single selection, it is used to create a primary key (context menu).)

I personally tend to choose to disable the column control.
Comment 5 ocke.janssen 2010-01-07 12:01:27 UTC
I now disable the column control when more than 1 column is selected. 
@all: Feel free to reopen it again if you prefer another solution.

Fixed in cws dba33e.
Comment 6 ocke.janssen 2010-02-10 09:08:19 UTC
Please verify. Thanks.

- Paste any table with more than 1 column into some db
- Go to the last page of the wizard
- Select more than one column
=> The control to change column attribs should be disabled
Comment 7 marc.neumann 2010-02-18 12:45:51 UTC
verified in CWS dba33e

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba33e