Issue 108040 - Connection type MSA-2007 changed to MSA-97 on error
Summary: Connection type MSA-2007 changed to MSA-97 on error
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 3.2 RC1
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks: 99999
  Show dependency tree
 
Reported: 2010-01-03 03:43 UTC by drewjensen.inbox
Modified: 2010-01-13 23:08 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
example ACCDB database (804.00 KB, application/vnd.ms-access)
2010-01-03 03:47 UTC, drewjensen.inbox
no flags Details
Bug doc - Base file after save and close (2.14 KB, application/vnd.sun.xml.base)
2010-01-03 03:48 UTC, drewjensen.inbox
no flags Details
patch as committed (for the record, for review, for ...) (773 bytes, patch)
2010-01-06 09:54 UTC, Frank Schönheit
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description drewjensen.inbox 2010-01-03 03:43:23 UTC
Checked with OOO320_RC1 / Win XP (SP3)

To Reproduce:

Download the attached file baseball.accdb
Create a Base file that connects to this file with the MS Access 2007 driver.
Save the Base file, close it and exit OO.o completely. 
Restart OO.o and open the Base file created above, attempt to connect to the 
database.
Error "not a valid file name"
Open dialog: Edit>Database>Properties
Notice that an extra '/' has been added to the end of the file name property.

At this point it looks like issue: 
http://www.openoffice.org/issues/show_bug.cgi?id=108019

Edit the file name property to remove the added '/' and save the change.
Try to connect to the database again.
Error: Unrecognized database format 'C:\Database\Baseball.accdb'

Open the dialog Edit>Database>Connection Type
The Database Type list has changed from MS Access 2007 to MS Access.
Change the Type back to MSA-2007 and this blanks the file name, reenter this and 
the connection is possible, until the file is closed and reopened again.
Comment 1 drewjensen.inbox 2010-01-03 03:47:10 UTC
Created attachment 66952 [details]
example ACCDB database
Comment 2 drewjensen.inbox 2010-01-03 03:48:32 UTC
Created attachment 66953 [details]
Bug doc - Base file after save and close
Comment 3 Frank Schönheit 2010-01-04 12:14:05 UTC
fs->oj: The problem here is that the new configuration data for does not really
distinguish between MSA and MSA2007 - both export the mime type
"application/msaccess". So, upon reading the .odb, the importer recognizes the
file as MSA, not MSA2007, since it has no other chance.

I'd say that we need another mime type here for MSA2007.

Also, I am not sure "application/msaccess" is really an official mime type. If
not, we should use "application/x-*" (but of course care for legacy documents then).
Comment 4 mdxonefour 2010-01-04 13:44:52 UTC
Adjusting target as announced on releases mailing list.
Comment 5 Frank Schönheit 2010-01-04 14:04:04 UTC
fixed in CWS dba32k

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba32k
Comment 6 Frank Schönheit 2010-01-05 14:50:03 UTC
fs->msc: please verify in CWS dba32k
Comment 7 Frank Schönheit 2010-01-06 09:54:30 UTC
Created attachment 67022 [details]
patch as committed (for the record, for review, for ...)
Comment 8 marc.neumann 2010-01-06 11:40:22 UTC
verified in CWS dba32k

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba32k
Comment 9 ocke.janssen 2010-01-06 11:49:08 UTC
Patch verified.
Comment 10 drewjensen.inbox 2010-01-13 23:08:28 UTC
Checked w/ XP OOO320_RC2

Forced the error by mangling file name property - close, open, error on connect, 
use dialog to fix name.

Closing