Issue 108130 - OpenOffice incorrectly applies colors from GTK theme
Summary: OpenOffice incorrectly applies colors from GTK theme
Status: CONFIRMED
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: 4.1.0-dev
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-07 13:55 UTC by mehanik
Modified: 2013-11-26 18:50 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mehanik 2010-01-07 13:55:10 UTC
This picture shows the bug:
http://pix.academ.org/img/2010/01/07/3f90290cfbd3c2e3a1cf3b6dcbdbccef.png

Color of the header table does not match the color set in the GTK theme. This
may not be bad, but text color is set so that it is almost not visible. I tried
to fix it by changing the color theme, but I failed.
Comment 1 annulen 2010-03-08 12:38:01 UTC
I have similar problem with light theme (http://rghost.ru/1121271.view). On 
screenshot you can see OOo (with missing borders, incorrect color of UI labels' 
text) alongside with native GTK application. 

I think this bug should be renamed into something like "OpenOffice incorrectly 
applies colors from GTK theme"
Comment 2 Edwin Sharp 2013-11-26 18:50:14 UTC
Assuming comment 2 of bug 108131 holds, confirmed with

AOO410m1(Build:9750)  -  Rev. 1539999
2013-11-09_04:08:11 - Rev. 1540252
Debian