Issue 108319 - wrong column length read from boundfield in base form
Summary: wrong column length read from boundfield in base form
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: MySQL Connector/OOo (show other issues)
Version: OOo 3.1.1
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: dbaneedsconfirm
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-14 12:39 UTC by kububa
Modified: 2012-09-09 05:58 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description kububa 2010-01-14 12:39:37 UTC
- Let's say I have a table `Users` in mysql database. I have two columns, `Id`
which is Int type and `Username` which is VARCHAR(255). 
- I have OpenOffice that uses Sun Mysql Native Connector.
- I create new form with wizard, open it to enter data and in textbox showing
`Username` column I can enter only 7 letters.
- In editing mode I see the length of textbox is set to 0.
- I manually define the length to 255 in editing mode of form, now I can enter
255 letters in this textbox in form.
- I open this table in OpenOffice Base, I can enter in `Username` column 255
letters, here everything is ok.

So, probably Openoffice (or rather the native mysql connector) improperly reads
the defined column length from the database, only in forms.

Please note this value is read properly, when I use ODBC driver.
Comment 1 drewjensen.inbox 2010-02-21 18:15:34 UTC
@kububa - Using Ubuntu 9.1, OOo 3.2, MySQL Connector 1.0, MySQL5.1 and can not
reproduce this issue. Is there any more information you can give, or hoave you
tried with the latest release of OOo?
Comment 2 kububa 2010-05-17 09:55:39 UTC
In OpenOffice 3.2, Ubuntu 10.04 it looks like this issue is fixed.
Comment 3 r4zoli 2012-09-09 05:57:49 UTC
Fixed during development.
Comment 4 r4zoli 2012-09-09 05:58:12 UTC
fixed-> closed.