Issue 108610 - Install of Non-JRE-build fails on WIndows 7
Summary: Install of Non-JRE-build fails on WIndows 7
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: OOo 3.2 RC4
Hardware: PC Windows 7
: P2 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: Martin Hollmichel
QA Contact: issues@installation
Keywords: oooqa
Depends on:
Blocks: 99999
  Show dependency tree
Reported: 2010-01-23 17:38 UTC by undertow
Modified: 2010-03-05 18:26 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description undertow 2010-01-23 17:38:01 UTC
Installation of 3.2 RC3 (English) on a newly installed Windows 7 Enterprise 
(Official Evaluation Copy). Installation fails with a failure to write 
msvcr90.dll. Installer is running privileged so that's not a problem. 
Installation of 3.1 on the same system works fine as I tried that after the 3.3 
RC3 install failed.
Comment 1 Rainer Bielefeld 2010-01-23 18:54:57 UTC
Not P1
Not reproducible with XP
Comment 2 undertow 2010-01-23 19:27:40 UTC
I can confirm that I don't see the problem with XP. However if this is a real 
bug preventing installation on a fresh install of Windows 7 Enterprise (and 
possibly all windows 7 systems) then I would think it should be P1

By the way anyone can download the 90 day evaluation copy of Windows 7 
Enterprise Evaluation edition direct from Microsoft if they want to try this 
out in a spare partition (16GB recommended)
Comment 3 i2initiatives 2010-01-25 06:12:37 UTC
I can confirm this on an activated Windows 7 Professional (32 bit) computer. The
setup gets to the very end - I can even see the brand new shortcuts in the start
menu, but then it stops with the error message and uninstalls everything.
Comment 4 i2initiatives 2010-01-25 06:24:56 UTC
Update - I re-downloaded the file and OOo 3.2 RC3 installed and started up fine
- no error message this time.
Comment 5 Risto Jääskeläinen 2010-01-25 07:37:46 UTC
I cannot reproduce this error when I install OOO320m10 (finnish RC3) after
OO320m1 on 64 bit Windows 7 Ultimate (evolution copy).  All is working correctly
as far I can see.

So this error is not totally general but it happens in some special situation?

Best regards
Risto J.
Comment 6 undertow 2010-01-25 13:51:22 UTC

Ok you saw the error as well confirming the problem but I am confused by the 
comment that you redownloaded and it installed fine, That seems to be 
suggesting there are different versions of the RC3 install. What's the 
difference between your second install binary and the first? If they are 
identical then I don't see why one would work and not the other.

This is 32 bit Windows 7 Enterprise in my case.
Comment 7 undertow 2010-01-25 18:53:03 UTC
Ok I just tried this on another PC with a fresh install of

Exactly the same problem - install almost completes but fails near the end with
the same write failure followed by a roll back. As ivantm says I also see the
desktop shortcut appear for 3.2 before the rollback undoes everything.

Windows Enterprise 32 bit Build 7600
Comment 8 merschmann 2010-01-26 12:19:52 UTC
Confirming with RC4. 

Happens with non-JRE-builds only as reported on german
Comment 9 Olaf Felka 2010-01-26 12:51:28 UTC
Signed installation files without JRE are defect (except en_US!?). The related
unsigned files are ok.
Comment 10 Martin Hollmichel 2010-01-26 13:08:27 UTC
according to my log file ar, da, el, en-US, es, fr, gl, it, ja, ko, lt, mk, nb,
nl, nn, pl, pt, ru, sh, sl, sr, tr, vi, zh-CN, zh-TW should be ok.

I'll check the remaining install sets.
Comment 11 Olaf Felka 2010-01-26 13:23:32 UTC
I've picked up 'fr' and can confirm that the signed files install ok.
Comment 12 merschmann 2010-01-27 08:26:12 UTC
Found fixed in newly uploaded version for de.
Comment 13 Olaf Felka 2010-01-27 08:56:06 UTC
Comment 14 undertow 2010-01-27 12:39:43 UTC
Confirming fixed in latest upload of RC4
00125_Win32Intel_install_en-GB.exe ( 26-Jan-2010 14:59  128M )
Comment 15 Olaf Felka 2010-01-27 13:01:28 UTC
Due to the last coments I think we can close this issue.
Comment 16 brian_a 2010-01-28 12:21:51 UTC
I downloaded and installed 3.2 RC4 (US English version - no JRE) and experienced the exact same failure 
to write msvcr90.dll and subsequent rollback of the installation.  I have no issue installing 3.1.1.  It seems 
that "fix" in 3.2 RC4 may not be consistent across all the 3.2 RC4 downloads.  I amable to install OO 3.1.1 
with no difficulty.  System is Atom based netbook running vanilla Windows 7 with virtually no additional 
software installed.
Comment 17 jolatt 2010-01-28 17:02:24 UTC
I have no problem to install the US version using setup -a because I have
installed the RC4 in German. Think that's irrelevant.
BS: Windows 7
Comment 18 trajj 2010-01-28 21:46:13 UTC
I've tried installing 3.2 RC4 on two different machines -- one running Windows 7
Professional and one running Windows 7 Home Premium -- and both failed. I had
previously installed RC3 on both machines successfully.
Comment 19 Olaf Felka 2010-01-28 21:57:10 UTC
We still have issue 108728. The upload for these files is on track.
Comment 20 mhinze 2010-03-05 18:26:26 UTC
When I try to install 3.2 on my Vista OS, I get an error message stating I am 
trying to install an older version over a newer version and I need to uninstall 
the newer one.  There is NO version of Open Office on my computer.  Please 
help.  I'm anxious to use your software.