Issue 108874 - [From Symphony] Worksheet.Change event works not correctly
[From Symphony] Worksheet.Change event works not correctly
Status: CLOSED FIXED
Product: App Dev
Classification: Unclassified
Component: vba
OOo 3.3 or older
All All
: P3 trivial
: 4.0.0
Assigned To: Chen Peng
noel.power
:
Depends on:
Blocks: 121368 121425
  Show dependency treegraph
 
Reported: 2010-02-03 06:40 UTC by lihuiibm
Modified: 2013-07-11 12:49 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Fix for this issue (5.99 KB, text/plain)
2010-02-03 06:40 UTC, lihuiibm
no flags Details
New patch(Remove windows crlf and no unrelated patch hunks ( e.g. Pivot table )) (4.15 KB, text/plain)
2010-04-30 09:54 UTC, lihuiibm
no flags Details
Updated patch for AOO 3.4 (3.50 KB, patch)
2012-02-24 18:28 UTC, Pedro Giffuni
no flags Details | Diff
patch for bug 108874 (3.50 KB, patch)
2012-08-22 08:11 UTC, Chen Peng
chenpeng2006: review? (pfg)
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description lihuiibm 2010-02-03 06:40:30 UTC
1. Root Cause:
Currently, when change the range by API, the worksheet change event is not
fired. So when change the range content, can't receive the worksheet_change event.
2. Resolution:
Fires the "cell-change" event when the range is changed.
Comment 1 lihuiibm 2010-02-03 06:40:59 UTC
Created attachment 67554 [details]
Fix for this issue
Comment 2 noel.power 2010-02-22 20:17:44 UTC
* please no windows crlf
* please no unrelated patch hunks ( e.g. Pivot table )
* instead of ClearContents, ClearComments etc. all calling
lcl_NotifyRangeChanges just ScVbaRange::ClearContents( sal_Int32 nFlags ) should
call lcl_NotifyRangeChanges 
* probably doing the search for what is going to be replaced is not that
efficient, the notification may need in the future to move somehow into the
replaceable implementation ( however lets not do that unless we see there is a
need to do that )
Comment 3 noel.power 2010-03-09 12:19:52 UTC
please take over and commit, also should be upstreamed
Comment 4 piviul 2010-03-09 14:34:33 UTC
Hi, I'm not a developer but I miss very much the worksheet_change event in
openoffice. I don't know if the lihuiibm patch solve the problem but I hope to
see soon the workseet_change event in the list of events in
Tools->Customise->events tab. Furthermore I've seen I'm not the only one who
miss the worksheet_change event. A lot of people that is trying to migrate from
ms office to openoffice have the same trouble.

Thank you very much lihuiibm I hope to see your patch in the openoffice main branch

Piviul
Comment 5 noel.power 2010-03-10 09:45:52 UTC
re-assign
Comment 6 lihuiibm 2010-04-30 09:54:32 UTC
Created attachment 69182 [details]
New patch(Remove windows crlf and no unrelated patch hunks ( e.g. Pivot table ))
Comment 7 lihuiibm 2010-04-30 09:57:04 UTC
>>instead of ClearContents, ClearComments etc. all calling
lcl_NotifyRangeChanges just ScVbaRange::ClearContents( sal_Int32 nFlags ) should
call lcl_NotifyRangeChanges 
From Hui Li: Because Range.ClearComments does not trigger the worksheet_change
event, so I did not call lcl_NotifyRangeChanges in ScVbaRange::ClearContents(
sal_Int32 nFlags ).
Comment 8 noel.power 2010-05-04 09:51:19 UTC
>Because Range.ClearComments does not trigger the worksheet_change
>event, so I did not call lcl_NotifyRangeChanges
ah ok!! didn't realise that, makes sense then, looks good
Comment 9 Pedro Giffuni 2012-02-24 18:28:48 UTC
Created attachment 77248 [details]
Updated patch for AOO 3.4
Comment 10 Chen Peng 2012-08-22 08:11:26 UTC
Created attachment 79062 [details]
patch for bug 108874

Updated the patch for AOO3.5
Comment 11 SVN Robot 2012-08-22 19:53:59 UTC
"pfg" committed SVN revision 1376211 into trunk:
#i108874# - Worksheet.Change event fix.Fire the "cell-change" event when the ...
Comment 12 Pedro Giffuni 2012-08-22 19:55:36 UTC
Thank you for the contribution/review.
Comment 13 Shenfeng Liu 2012-10-18 05:30:36 UTC
Update Target Milestone to AOO 3.5.0.
Comment 14 binguo 2012-12-14 09:11:10 UTC
Latest build is Aoo_Trunk_20121207.1915 Rev.1413470, marked is as verified.
Comment 15 binguo 2012-12-14 09:11:22 UTC
close it.