Issue 109063 - selected grid font-resize problem
Summary: selected grid font-resize problem
Alias: None
Product: Impress
Classification: Application
Component: editing (show other issues)
Version: OOo 3.2
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2010-02-09 04:43 UTC by gaeran
Modified: 2017-05-20 11:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description gaeran 2010-02-09 04:43:06 UTC
OS : Linux KEVLAB #1 SMP Mon Jan 18 19:52:07 UTC
2010 x86_64 x86_64 x86_64 GNU/Linux
OpenOffice Ver: 3.1.1 & 3.2(candidate version)

1. Make new grid x5 * y10(what ever)
2. select cells as (x1,y2) to (x5,y6).
3. click font size-down or size-up button.
4. All fonts (include out of selected) re-sized.

I think it should be re-sized what I selected.
Comment 1 maand 2010-02-09 20:49:07 UTC
Please give an information why this is an issue of the program modul Impress
Comment 2 gaeran 2010-02-11 23:21:48 UTC
I would like to change font size for I selected-cells not for all cells.
On MS-PowerPoint it is not happend.
Comment 3 mlahrech 2010-03-27 13:02:31 UTC
Mohamed J. Lahrech, more info on this issue
The issue is also reproducible on:
Windows XP SP3 Home with OOo-dev 3.3.0, DEV300m75 build:9488
Windows XP SP3 Professional with OOo 3.2.0, OOO320m12 build:9483

Steps to reproduce:
1- Open or Create a new Impress document
2- Create a table: e.g. 4 rows and 5 columns (not necessarily in a new slide)
3- Fill the cells with text.
4- Select one or a group of cells. 
5- Click on Increase Font button on Text Formatting Bar (same behavior with 
Reduce Font button)

Result: All Cells, selected and not selected ones, have been update with the 
font size change.
Expected : Only selected cells should be updated.

Other observations:
1.When you select the text of a cell (not the cell it self) the Increase 
Font/Reduce Font is applied only on the selected text. However text selection 
does not permit to select more than one cell. So the bug does not happen in 
case of text selection but in case of cell selection.

2.When you change the size of the text using the Font Size combo-box it works 
fine. So the issue is when using the Increase/Reduce Font buttons.

3.This issue seems to happen only with the font size buttons. I tried the other 
buttons like Bold, Underline, Justifications buttons...etc and they work fine.

4.I tested using different tables with different sizes, it seems that the table 
size has no impact on the issue.

5.I tried using different fonts and different languages (Latin and Arabic),  it 
seems that it has no impact on the issue too.

6.Number and position of selected cells seems to not have an impact because I 
tried with different combinations.

7.Same behavior has been noticed with OOo Draw  (Same configuration described 

Comment 4 maand 2010-05-01 18:03:02 UTC
The resize issue is visible not only on Linux. We verified it also on Mac and
Win in the QA Workshop in Essen.
If you mark two or more cells of the table and try to use the tool for the font
size in the menu bar text format, there is no change in the font size.
Comment 5 maand 2010-05-01 18:04:27 UTC
I think it's one for you.
Comment 6 clippka 2010-06-07 15:56:20 UTC
setting target
Comment 7 Marcus 2017-05-20 11:11:25 UTC
Reset assigne to the default "".