Issue 109109 - User-defined document property of type "date" displays as a number field value
Summary: User-defined document property of type "date" displays as a number field value
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 3.1.1
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-10 14:39 UTC by windl
Modified: 2017-05-20 11:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample that doesn't display the field's value (StarOffice 9.1) (7.57 KB, application/vnd.oasis.opendocument.text)
2010-02-10 14:40 UTC, windl
no flags Details
Sample file where the field's value is displayed (StarOffice 9.1) (7.64 KB, application/vnd.oasis.opendocument.text)
2010-02-10 14:41 UTC, windl
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description windl 2010-02-10 14:39:07 UTC
When setting a user-defined document property of type "date" (new in OOO 3), the
set value isn't displayed when a corresponding field is inserted to the
document. When changing the user-defined property to type "text" however, the
value is displayed. I'll add to samples:
date0.odt: field's value isn't displayed
date1.odt: field's value is displayed

Note: I could not find out what the intended use of the types in user-defined
properties was intended for, but it can't be that wrong to set the type of a
date to "date", right?
Comment 1 windl 2010-02-10 14:40:24 UTC
Created attachment 67728 [details]
Sample that doesn't display the field's value (StarOffice 9.1)
Comment 2 windl 2010-02-10 14:41:14 UTC
Created attachment 67729 [details]
Sample file where the field's value is displayed (StarOffice 9.1)
Comment 3 mst.ooo 2010-02-11 10:35:13 UTC
the document "date0.odt" contains a plain user-defined field without a style for
a date user-defined property:

  <text:user-defined text:name="Date"/>

DEV300m71 cannot display the field correctly: it displays a number instead of a
date.
as a workaround for such documents just click on the field and change the format
to a date format.

the original issue that such fields for date properties were not supported at
all is fixed on DEV300 (for OOo 3.3); if the document were created with OOo 3.3
the field would work.
Comment 4 Marcus 2017-05-20 11:15:26 UTC
Reset assigne to the default "issues@openoffice.apache.org".