Issue 109253 - Enhancemant LOOKUP-functions with optional "N/A-string"
Summary: Enhancemant LOOKUP-functions with optional "N/A-string"
Status: CLOSED DUPLICATE of issue 92677
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-14 13:05 UTC by user9591
Modified: 2010-02-15 12:46 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description user9591 2010-02-14 13:05:19 UTC
I use the Lookup-functions (also 'Match') a lot and I find it complicating to
always check for "N/A" results. The "N/A" result often looks ugly in a
spreadsheet. It makes the formula twice as long when you want to prevent the
"N/A" in a cell (if(iserror(blablabla).

It would be very convenient when an extra parameter could be added to the
lookup-functions: an optional string that is shown instead of the "N/A". I often
would then use "" (empty string) because I don't want to see anything in a cell
when nothing is found.

Example: VLOOKUP(SearchCriterion; Array; Index; SortOrder;
OptionalStringInsteadOf"N/A")

instead of IF(ISERROR(VLOOKUP(SearchCriterion; Array; Index; SortOrder);"Not
found";VLOOKUP(SearchCriterion; Array; Index; SortOrder)))

Would that be possible in the near future...? I hope so!
Comment 1 ooo 2010-02-15 12:45:28 UTC
Actually a use case for IFNA(), see issue 92677.

*** This issue has been marked as a duplicate of 92677 ***
Comment 2 ooo 2010-02-15 12:46:42 UTC
Closing.