Issue 109520 - Cyrillic historic+extended characters are not displayed in the Basic IDE
Summary: Cyrillic historic+extended characters are not displayed in the Basic IDE
Status: ACCEPTED
Alias: None
Product: App Dev
Classification: Unclassified
Component: scripting (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: Unknown All
: P4 Trivial
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2010-02-22 15:23 UTC by fyva
Modified: 2017-05-20 11:27 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
screenshot (10.84 KB, text/plain)
2010-02-22 15:24 UTC, fyva
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description fyva 2010-02-22 15:23:06 UTC
ѣ,Ѣ and similar characters are not displayed in the Basic IDE.
How to reproduce.
Open OOo Basic. Insert this text:
"ѢѣѤѥѦѧѨѩѪѫѬѭѮѯѰѱѲѳѴѵѶѷѸѹѺѻѼѽѾѿҀҁ҂҃҄҅҆҇҈҉ҊҋҌҍҎҏҐґҒғҔҕҖҗҘҙҚқҜҝҞҟҠҡҢңҤҥҦҧҨҩҪҫҬҭҮүҰұҲҳҴҵҶҷҸҹҺһҼҽҾҿӀӁӂӃӄӅӆӇӈӉӊӋӌӍӎӏӐӑӒӓӔӕӖӗӘәӚ".
Try to insert a space somewhere.

(You can get this text by running the macro:
Sub Main
TK = ThisComponent.Text.CreateTextCursor
S=""
For i=0 to 120
S=S+chr(1122+i)
Next
TK.String=S
End Sub)


You are going to see something like on the screenshot below. This is tested on
Ubuntu Linux 8.04 with OOo 3.2 (Russian and English) and DEV300m71 builds.

(This is a regression. This worked fine with 3.1.1.)
Comment 1 fyva 2010-02-22 15:24:56 UTC
Created attachment 67981 [details]
screenshot
Comment 2 fyva 2010-02-22 16:15:18 UTC
Windows XP + OOo 3.2 - the same issue as on Linux.
Comment 3 kay.ramme 2010-02-24 07:53:26 UTC
Andreas, please have a look.
Comment 4 ab 2010-05-28 14:06:29 UTC
ab->tl: I assume, this is related to the TextEngine,
please have a look

Comment 5 fyva 2010-05-28 14:25:55 UTC
This issue doesn't appear in Ubuntu 10.04+OOO320m18 and Ubuntu 10.04+DEV300m78,
but is still present in Windows XP SP2 + OOO320m18. This is perhaps due to using
the different font - Courier New. In Linux the font is DejaVu Sans Mono and
there are no problems. But with Courier New there is a problem even though it
seems all characters are presented in the font. BTW, if I paste this string
("ѢѣѤѥѦѧѨѩѪѫѬѭѮѯѰѱѲѳѴѵѶѷѸѹѺѻѼѽѾѿҀҁ҂҃҄҅҆҇҈҉ҊҋҌҍҎҏҐґҒғҔҕҖҗҘҙҚқҜҝҞҟҠҡҢңҤҥҦҧҨҩҪҫҬҭҮүҰұҲҳҴҵҶҷҸҹҺһҼҽҾҿӀӁӂӃӄӅӆӇӈӉӊӋӌӍӎӏӐӑӒӓӔӕӖӗӘәӚ")
in Writer in Windows XP SP2 with the default Times New Roman font, I get the
same result: only a few characters displayed correctly.
Comment 6 thomas.lange 2010-05-28 14:53:50 UTC
TL->HDU: In DEV300_m77 and OOO320_m12 (SO 9.2) with Windows most of the
characters (about 80+%) in the mentioned string get displayed correctly. Namely
ѣ and Ѣ are displayed fine.

Maybe it is a problem of the fonts installed on the system? (I tried to use font
replacement but don't remember anymore which font we are using in our UI.) :-(
Maybe you can shed some light in this issue. Please have look. Thanks!
Comment 7 hdu@apache.org 2010-05-31 13:51:36 UTC
@ab: extending OOo basic so that the fonts for the IDE, message boxes, print output etc. can be changed 
would help. Not all international users are well serviced with the one-size-fits-all setting.

Unless this enhancement request gets implemented Basic relies on the "glyph fallback" feature for chars 
that are not covered by Basic's default font. And this of course depends on the availability of other fonts, 
which is problematic if only for the reason that the resulting look is unpredicable. If one could request: "I 
want this font and this text" the result would be predicable.

Other than that I'd like to mention that on WIN glyph fallback has been recently improved with issue 
101552 which got into DEV300_m78 an newer.
Comment 8 ab 2010-06-03 11:03:27 UTC
STARTED, OOo 3.x
Comment 9 kai.sommerfeld 2011-02-09 16:10:18 UTC
.
Comment 10 Marcus 2017-05-20 11:27:48 UTC
Reset assigne to the default "issues@openoffice.apache.org".