Issue 109556 - paste special with link of an empty cell doesn't link anything
paste special with link of an empty cell doesn't link anything
Status: CONFIRMED
Product: Calc
Classification: Application
Component: editing
OOo 1.0.0
All All
: P2 trivial with 1 vote (vote)
: ---
Assigned To: AOO issues mailing list
:
Depends on:
Blocks: 97765
  Show dependency treegraph
 
Reported: 2010-02-24 00:23 UTC by pposc
Modified: 2013-08-20 12:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description pposc 2010-02-24 00:23:37 UTC
When copying a non empty cell (e.g. A1) using the option "link" of "paste
special", the result is a link to the source cell:
=$Sheet1.$A$1

When doing the same with an empty cell, we should expect the same formula as a
result. However, Calc doesn't copy anything (the result is an empty cell, of
course, but with no link at all with the source cell).

This behaviour is annoying when we like to copy/paste+link a set of cells, some
of them empty. Only the non empty cells are linked to the destination cells. If
the empty source cells are later populated, the destination cells will remain
empty (because they are not linked).
Comment 1 pposc 2010-02-24 00:28:18 UTC
We have tested OOo 2.0 - 2.4.3 - 3.1.1 on Windows XP and Linux (Fedora) : same
behaviour
Comment 2 Edwin Sharp 2013-08-20 12:56:22 UTC
As given in description.

Rev. 1514603 Win 7.