Issue 109592 - ES: Localized Spanish shortcuts are not correctly mapped anymore
Summary: ES: Localized Spanish shortcuts are not correctly mapped anymore
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 3.2
Hardware: All All
: P3 Trivial with 4 votes (vote)
Target Milestone: OOo 3.2.1
Assignee: eric.savary
QA Contact: issues@framework
URL:
Keywords:
: 102645 (view as issue list)
Depends on:
Blocks:
 
Reported: 2010-02-25 10:15 UTC by Olaf Felka
Modified: 2017-05-20 10:24 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Olaf Felka 2010-02-25 10:15:38 UTC
Found in OOo 320_m12_es. The keyboard shortcut for 'Select all' should be
'Control + E'. If you press 'Control +E' the text will be centered instead.
Comment 1 Olaf Felka 2010-02-25 16:39:39 UTC
reassigned
Comment 2 ooo 2010-02-25 17:55:35 UTC
Apparently

svx/uiconfig/accelerator/es/default.xml
    <accel:item accel:code="KEY_E" accel:mod1="true" xlink:href=".uno:SelectAll"/>

gets overwritten by

sw/uiconfig/swriter/accelerator/en-US/default.xml
    <accel:item accel:code="KEY_E" accel:mod1="true" xlink:href=".uno:CenterPara"/>

because sw/uiconfig/swriter/accelerator/es/default.xml doesn't define Ctrl+E on
its own.

Isn't that inheritance mechanism somewhat broken? It looks like an application's
localization has to define all keys that are assigned in en-US even if a key is
already assigned in svx, if I'm not mistaken.
Comment 3 jsimr 2010-02-25 18:14:12 UTC
I have added: 
<accel:item accel:code="KEY_E" accel:mod1="true" xlink:href=".uno:SelectAll"/>

to
"/opt/openoffice.org/basis3.2/share/config/soffice.cfg/modules/swriter/accelerator/es/default.xml"

but the bug continues.
Comment 4 troodon 2010-02-26 21:19:48 UTC
Dupe of issue 101699.
Comment 5 acolorado 2010-03-09 23:41:49 UTC
Other issues with accelerators include:
Ctrl-E should execute Select ALL 
Ctrl-T should be center paragraph 
Ctrl-D should push paragraph to the right
Ctrl-G should save
Ctrl-Q align paragraph to the left
Ctrl-B puts bold but should be Ctrl-N
Ctrl-B should do a search
Ctrl-U should be new document
Ctrl-i/k are repeated for italics (should be just i)
Ctrl-s/u are repeated for underline (should be just u)

This is a complete reference shortcuts for Word program (in spanish):
http://www.gratiszona.com/trucos/trucos_word/las_teclas_rapidas.htm
Comment 6 acolorado 2010-03-09 23:44:12 UTC
Added three testers for QA the changes
Comment 7 wuyan.ooorg 2010-03-10 02:49:10 UTC
The keyboard shortcuts have been moved from XML to XCU. Currently all keys for
en-US and other localization languages are defined in Accelerators.xcu, which
was generated according the original files in
<OFFICE_INSTALL>/.../config/soffice.cfg/.../accelerator/*.xml. There are some es
keys which are defined in svx, but missed in
<OFFICE_INSTALL>/.../es/default.xml. Now those missing keys should be added to
the Accelerators.xcu.

wuy->cd: Carsten, have you fixed this problem, or could I take over it?

Regards,
Yan
Comment 8 carsten.driesner 2010-03-24 10:09:53 UTC
cd->wuyan: I am working on this issue.
Comment 9 eric.savary 2010-03-24 12:45:13 UTC
@All: Change summary to match better the issue.

@JZA: This issue is a regression compared to an older milestone in which the
defined shortcuts[1] where working.

What you propose is an enhancement introducing new shortcuts.
Please file a new issue for this but please check in detail the matching between
a Spanish MS-Word and the existing OOo shortcuts!
For example: you propose Ctrl+Q for left aligned. So where will "Exit"
(currently Ctrl+Q) be remapped to? To be discussed in the new issue... 

[1] See "6.4 G11n" in http://specs.openoffice.org/g11n/menus/LocalizedShortcuts.sxw
Comment 10 carsten.driesner 2010-03-24 15:44:42 UTC
cd: Fixed. Now shortcuts are assign as defined by the specification: 
http://specs.openoffice.org/g11n/menus/LocalizedShortcuts.sxw

cd->es: Please check carefully as I had to change many entries in the
Accelerators.xcu.
Comment 11 Oliver-Rainer Wittmann 2010-03-31 14:34:46 UTC
OD->ES: Please check and verify in internal installation set of cws sw321bf01 - Thx.
Comment 12 eric.savary 2010-04-06 13:16:55 UTC
Verified in CWS sw321bf01.
Comment 13 carsten.driesner 2010-04-08 09:13:49 UTC
*** Issue 102645 has been marked as a duplicate of this issue. ***
Comment 14 acolorado 2010-04-15 19:55:12 UTC
3.2.1 still present the same issue.
Comment 15 eric.savary 2010-04-15 20:01:54 UTC
Yes, it will be integrated in OOO320m15.
Comment 16 acolorado 2010-04-15 20:37:22 UTC
Ok missunderstanding solved, seemed the fix is schedule for m15

@wuy -> Ctrl-Q is good for english (Quit) but spanish (Salir) doesn't make much 
sense. In Word (and most window manager) this is directed to Alt-F4 which will 
exit the app. This also works in english versions since is a window manager 
shortcut as opposed to a OOo-centric one.

Same goes for "Cerrar" (Close) with Ctrl-W in spanish is stablish to Ctrl-R to 
close a document. Currently is set to Right align which doesn't make sense to 
right (derecha) alignment.

I will start research on this and compare it to other applications like 
AbiWord, KOffice and see if there is a standar on these behaviors.

Regards.
Comment 17 eric.savary 2010-04-15 21:21:26 UTC
@JZA: As I already told you in #desc10 we are not discussing here *improvements*
in localized shortcuts but the *fix* of a regression.
Please write an enhancement for improvements.