Issue 110263 - Wrong data formating in import from .cvs
Summary: Wrong data formating in import from .cvs
Status: CLOSED DUPLICATE of issue 87999
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOO310m11
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2010-03-19 16:54 UTC by gregorystec
Modified: 2010-03-20 12:15 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The example file to import. (158 bytes, text/plain)
2010-03-19 16:57 UTC, gregorystec
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description gregorystec 2010-03-19 16:54:50 UTC
In case when the data field is two digit number ended with dot (XX.) or group up
t three) of two digit number separated with dot (XX.XX.XX.) the standard
conversion for this field is to data format dd.mm.yyyy (system date format). 
For example the number:
"10." is converted to "10.03.2010"
"10.10" is converted to "10.10.2010"
"12.11.15" is converted to "12.11.2015"
The incomplete group of digit is substituted from system date.
If the imported .cvs is very huge and some of column is mixed type text with
numbers, the result is little frustrating.
The system number decimal separator is "." and sytem data format is "dd.mm.yyy",
polish location (pl-PL)
Comment 1 gregorystec 2010-03-19 16:57:00 UTC
Created attachment 68438 [details]
The example file to import.
Comment 2 Rainer Bielefeld 2010-03-20 12:15:18 UTC
Known problem!


*** This issue has been marked as a duplicate of 87999 ***
Comment 3 Rainer Bielefeld 2010-03-20 12:15:41 UTC
.