Issue 110316 - the "key press" event doesn't get called when the generating control is a textbox in a gridcontrol with multtiline property set to true
Summary: the "key press" event doesn't get called when the generating control is a tex...
Status: CLOSED DUPLICATE of issue 110314
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOO320m12
Hardware: PC Windows Vista
: P3 Trivial (vote)
Target Milestone: ---
Assignee: dbaneedsconfirm
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-22 18:23 UTC by kompix69
Modified: 2010-03-23 11:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description kompix69 2010-03-22 18:23:35 UTC
In an Base document I created a form that contains a grid control. 
When editting the form:
-Assign a macro for the "key pressed" event of the grid control (p.e. 
"grid_key_pressed")
-Do the same for two different columns in the grid control (let's call them 
Col1 and Col2). Both columns are of "Text Box" type. Let's call the associated 
macros col1_key_pressed an col2_key_pressed.
-set property "Multiline input" ("General" tab) to "no" for Col1 and to "yes" 
for Col2
-Save and close

When you open the form, and type something inside Col1, grid_key_pressed gets 
called first, and then col1_key_pressed. But when you type in col2 neither 
grid_key_pressed nor col2_key_pressed get executed.

Edditing the form and setting col2 multiline property to "no" makes col2 fire 
both macros grid_key_pressed and col2_key_pressed.
Comment 1 r4zoli 2010-03-23 11:39:46 UTC
duplicate

*** This issue has been marked as a duplicate of 110314 ***
Comment 2 r4zoli 2010-03-23 11:44:01 UTC
closing