Issue 110506 - 3D object interactions lost when upgrading Open Office
Summary: 3D object interactions lost when upgrading Open Office
Alias: None
Product: Impress
Classification: Application
Component: programming (show other issues)
Version: OOO320m12
Hardware: Sun Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo
Depends on:
Reported: 2010-03-30 20:29 UTC by kerryober
Modified: 2017-05-20 11:08 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

2 slides that should interact but do not (17.62 KB, text/plain)
2010-03-31 16:05 UTC, kerryober
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kerryober 2010-03-30 20:29:45 UTC
The previous version of OOO 3.2 that I was using (I am not sure which build) had
problems with 3D objects displaying and copying correctly, but I used them
anyway.  I assume some changes were made to the code handling these objects.  A
side effect of these assumed changes is that at least one of the object
interactions that worked before no longer work.  At least the "Go to page or
object:xxx" interaction is broken.
Comment 1 wolframgarten 2010-03-31 08:00:32 UTC
Please attach a document to reproduce. Did you use the version 3.1.1 before?
Comment 2 kerryober 2010-03-31 16:05:11 UTC
Created attachment 68672 [details]
2 slides that should interact but do not
Comment 3 kerryober 2010-03-31 16:23:05 UTC
I am no longer sure what version I was using before.  I thought and reported
that it was 3.2.  However, when I choose Start->All Programs I see an empty 3.1 folder that I used to use and a new 3.2 folder
that has the newer version.  I suggest it is safe to assume I was using 3.1 before.

In the attached file, there are 2 slides out of about 100 that I had working
interactions for.  Each of the 3D triangular objects in the lower half represent
buttons.  Press one (in particular the yellow one) and a new slide should appear
(in particular, the next slide.)  The interaction that used to be there (Go to
page or object SetupDsp) is no longer there.  In addition, I cannot add a new
one nor replace the one that should be there.
Comment 4 Joost Andrae 2010-03-31 16:38:41 UTC
I cannot confirm this on Solaris x86. Interactions work well. Tested with
OOO320_m14 and I cannot confirm this on Windows using OOo 3.2.0 release build
provided by Sun
Comment 5 kerryober 2010-03-31 17:31:18 UTC
I am a little confused.

I uninstalled the m12 build I was using and again downloaded the build provided
by the website for Windows.  The Help-About information confirms the
build is m12 provided by Sun.  The problem I have described is still present.

ja indicates that the problem cannot be confirmed on Solaris x86, build m14.  On
the surface, it seems the test was done on a different operating system with a
different build.  Yet the comment also says the problem cannot be confirmed on
Windows using the release build provided by Sun.  Was the confirmation test
performed using build m12 on Windows XP, or was it done on Solaris using build m14?
Comment 6 kerryober 2010-03-31 21:16:56 UTC
I can contribute additional information:

To continue using my slides as I wish, I "uninstalled" 3.2 and reinstalled 3.1.
 Trying to open the file directly caused OO to crash and the recovery process
did not work.  Opening OO then opening the odp file allows me to see the slides
but all interaction is missing.  But at least now I can recreate the
interactions whereas in 3.2 I could not do even that.  This suggests to me there
is something about storing the interactions in the file that is messed up.
Comment 7 wolframgarten 2010-04-01 11:02:48 UTC
I have loaded your file in version 2.11, 3.0., 3.1.1 and 3.2 and in none of them
there is a target assigned.  The interaction is assigned but without a target.
I loaded the file in 3.1.1 again, assigned an interaction and saved it. Loading
it in 3.2 and m75 shows me no interaction target. Additional the selection of
the 3d object is not possible using the mouse. TAB helps to select it.
@kerryober: is that why you could not assign an interaction?
Comment 8 wolframgarten 2010-04-01 11:04:45 UTC
Comment 9 kerryober 2010-04-01 20:20:50 UTC
It is true that the file I sent you does not have any interactions.  I believe
this is true because 3.2 destroyed them. (But I may be wrong, see my previous
comment.)  I tried to add an interaction using 3.2 but could not.  The purpose
of the file was to provide a case where interactions that existed in 3.1 do not
work in 3.2.  Each of the 3D "buttons" in the main slide had a "Go to"
interaction in 3.1.  I only included the slide for the yellow button "Go to" in
the file.  I can provide others if you want/need.

When I used 3.2 on the file I sent you I did not have any problems that I
noticed using the mouse to select any of the 3D objects.  I could select an
object with a left click, open the object menu with a right click, select
Interaction from the menu to display the interaction dialog, choose the "Go to
object or page:" action, select a page from the list, and click OK.  However,
performing those actions did not create/store an interaction.

I should make it clear that 2D interactions still work in 3.2 (I use some of
those too) so the issue is 3D object related only.
Comment 10 clippka 2010-06-07 16:01:00 UTC
this is a dupe I already fixed it some time ago. please check OOo 3.2.1 version
Comment 11 clippka 2010-06-07 16:01:21 UTC
Comment 12 kerryober 2010-06-20 01:06:56 UTC
I downloaded 3.2.1 from and installed it on my
machine.  The problem as described is still present.

I notice that I do not even get the option to try to create an interaction in
3.2.1 as I could in 3.2 (which did not work) and in 3.1.  From a user
perspective this problem is getting worse, not better.
Comment 13 Marcus 2017-05-20 11:08:33 UTC
Reset assigne to the default "".