Issue 110542 - WW: Tabulations linked to paragraph styles are incorrectly positioned when converting .ODT to .DOC
Summary: WW: Tabulations linked to paragraph styles are incorrectly positioned when co...
Status: CLOSED DUPLICATE of issue 19654
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOo 3.2
Hardware: Unknown All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-01 10:38 UTC by cutter
Modified: 2010-04-06 12:12 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Test case. Save this file as .doc using OOo Writer 3.2. (8.40 KB, application/vnd.oasis.opendocument.text)
2010-04-01 12:05 UTC, cutter
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description cutter 2010-04-01 10:38:11 UTC
In the ODT format, tabulations are positioned relatively to the "Before text"
indent. When an ODT document is saved as DOC, tabulations linked to paragraph
styles are suddenly positioned relatively to the page's "Left margin" instead.
If the "Before text" indent is not aligned with the page's left margin, this
messes the tabulations' positions.

This bug appeared in OOo 3.2.
Steps to reproduce it:
1. Start a new document with Writer
2. Set the "Before text" indent to about 3cm (bottom triangle on the ruler).
3. Put a tabulation at 10cm.
4. Press F11 to open the Styles and Formatting dialog.
5. Create a paragraph style by clicking on "New style from selection" > "New
style from selection". Name it and click OK.
6. Save the document as ODT.
7. Save the document as DOC.
8. Reload the DOC document (File > Reload).
9. The tabulation should have moved from 10cm to 7cm.

This bug doesn't occur if the document is directly saved as DOC (no conversion
from ODT). It only concerns tabulations linked to paragraph styles. Tabulations
created independently don't seem to be affected.
Comment 1 cutter 2010-04-01 12:05:29 UTC
Created attachment 68688 [details]
Test case. Save this file as .doc using OOo Writer 3.2.
Comment 2 michael.ruess 2010-04-06 12:12:40 UTC
Same root cause as issue 19654.

*** This issue has been marked as a duplicate of 19654 ***
Comment 3 michael.ruess 2010-04-06 12:12:59 UTC
Closing dup.