Issue 110543 - No connection to OOo from Java on Mac OSX 10.6.2
Summary: No connection to OOo from Java on Mac OSX 10.6.2
Alias: None
Product: porting
Classification: Code
Component: MacOSX (show other issues)
Version: OOo 3.2
Hardware: Mac Mac OS X 10.6
: P5 (lowest) Trivial (vote)
Target Milestone: ---
Assignee: ericb
QA Contact: issues@porting
Depends on:
Reported: 2010-04-01 10:58 UTC by wolfgangg
Modified: 2017-05-20 09:13 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description wolfgangg 2010-04-01 10:58:18 UTC
When I build a new project in NetBeans that contains already the line
XComponentContext xContext = Bootstrap.bootstrap();
and execute the project in the debugger then the program jumps to the end of the current function 
without doing anything or throwing any exception or message.
At this time the following message occurs in the system console:

dlopen(/Applications/, 1): no 
suitable image found.  Did find:
	/Applications/ mach-o, but 
wrong architecture

My real project that shows the same problem works on Linux.
Could this problem be related to Issue 108457 ?
There should be a developer snapshot of OOo 3.2.1 (OOO320_m14), but the installer is not on the 
download page.
I have also tried the snapshot OOo-Dev_DEV300_m75, but the problem is the same.

Comment 1 jsc 2010-04-01 13:15:00 UTC
it's the 64bit problem. You run a 64bit Java and the bootstrap mechanism tries
to find a 64 bit jpipe library which does not exist. As long as this problem
isn't solved you should run your Java application with the JVM option -d32. In
NetBeans for example you can simply specify it in the project properties.
Comment 2 jsc 2010-04-01 13:15:26 UTC
cc jsc
Comment 3 wolfgangg 2010-04-01 13:52:01 UTC
Thanks for this quick solution.