Issue 110572 - Constant crashes
Summary: Constant crashes
Status: UNCONFIRMED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 3.2
Hardware: Mac Mac OS X 10.6
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks:
 
Reported: 2010-04-02 20:09 UTC by bronwynboltwood
Modified: 2014-07-19 22:00 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
crash report after opening OO preferences (101.45 KB, text/plain)
2010-04-03 03:37 UTC, bronwynboltwood
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description bronwynboltwood 2010-04-02 20:09:18 UTC
When I try to use OpenOffice it now crashes constantly, The program is no longer
usable. I only really use the Writer and Calc, and occasionally Impress. 

Originally, with Snow Leopard and (I think) OO 3.1.1 it worked ok -- only
crashed occasionally. At some point I let it upgrade to OO 3.2 and crashes got
much more frequent: I could not open Calc at all, and Writer crashes increased
to the point where it too could not run. This may have started under OSX 10.6.2,
or maybe only after upgrading to 10.6.3.

I tried deleting my OO profile (under my account, then Library, then Application
Support) as many webpages and forum posts advised, and that let OO open again.
And then it started crashing again. I removed OO and reinstalled a fresh copy
off the web, with a new profile. Same problems with crashing except that I
discovered an even more efficient method: open the preferences, and it crashes
right away! 

I removed OO entirely, decided that maybe 3.2 was the problem, and scoured the
internet for a copy of 3.1.1 which the folks writing your download page have
made an absolutely miserable job. I deleted the OO profile again and installed
3.1.1.  Now 3.1.1 won't work on this machine either -- it has exactly the same
problems as 3.2 before it, despite multiple removals and reinstalls including
the OO profile.

I have tried autorecovering the files I was working on, and not autorecovering
them, and it makes no difference. I would delete the ones it has stored, in case
they are causing the crashes, but I can't find out where they are because the
paths listing is in the preferences, and opening that crashes the program within
moments. It will also happily crash on new blank documents, especially in Writer.

Please fix this. I use OpenOffice for school, and now all existing documents in
it are inaccessible until this is resolved.
Comment 1 bronwynboltwood 2010-04-02 20:31:22 UTC
Okay, I have tested OO 3.1.1 in another account on the same machine, and it
seems to work there. I only tried opening some new documents and the
preferences, but it wasn't crashing immediately.

Therefore whatever is wrong is related to something in my user profile. 

Surely there will be a better way to fix OO than to delete and recreate my
entire user profile? 
Comment 2 eric.savary 2010-04-02 21:57:04 UTC
As you experienced, your crashes are probably linked to an instable environment
(your profile or something else).

We cannot fix crashes just because you say "fix it!". We need detailed info and
especially a reproducible scenario.

So next time it crashes (please use 3.2 we don't fix for 3.1.1 anymore) please
send a crash report adding your e-mail address in the corresponding field of the
crash reporter.
You will get a crash report number by e-mail which you can post here.

This will help much more than everything you have described here.
Comment 3 bronwynboltwood 2010-04-03 03:37:37 UTC
Created attachment 68714 [details]
crash report after opening OO preferences
Comment 4 bronwynboltwood 2010-04-03 03:48:06 UTC
Sorry to have come across badly; I was irritated at having spent hours and hours
trying to fix this with no success, because the more work time I miss, the more
sleep I have to miss not to fall behind. I've installed a copy of NeoOffice
which works so far, and that takes some pressure off fixing this.

I have reinstalled OO 3.2 and attached a crash report from the crash that
happens from opening the preferences dialog. Now that I want the crash report
from opening an autorecover document, of course that works. :)

It only offers to send a crash report to Apple.  Is that normal, or should there
be an OO crash reporter coming up too?

Let me know how else I can help, and thank you for answering so quickly, on a
holiday too.
Comment 5 Rob Weir 2013-02-02 02:59:12 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 6 Chris 2014-07-19 22:00:19 UTC
Other posts I see re: constant crashes are at least 4 years old and not pertinent to the most recent release. I have 4.1.0 on W 7 laptop. I can't use anything at all or recover any documents. It was working fine until the new upgrade.