Issue 110720 - Aborting when "UI-language cannot be determined" since DEV300_m76
Summary: Aborting when "UI-language cannot be determined" since DEV300_m76
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: DEV300m76
Hardware: All All
: P2 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: Olaf Felka
QA Contact: issues@framework
Keywords: oooqa
: 112103 (view as issue list)
Depends on:
Blocks: 110102 112263
  Show dependency tree
Reported: 2010-04-09 12:37 UTC by
Modified: 2017-05-20 10:22 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description 2010-04-09 12:37:20 UTC
Since the changes introduced by CWS native0 to DEV300_m76's desktop/source/app if there are problems 
with the application trying to determine the prefered language then it aborts with:
    "The application cannot be started.
    The user interface language cannot be determined."

Aborting in this case is much too heavy, it should simply fall back to any of the installed UI-languages. 
More often than not it is exactly one, so things are simple. Since the error message is also localized (or is 
it hardcoded in English?) then this information should be readily available. If not then falling back to just 
English would be much better than aborting.
Comment 1 Rainer Bielefeld 2010-04-12 05:40:04 UTC
Related to Issue 110102?
Comment 2 2010-04-12 07:47:23 UTC
Yes, issue 110102 is at least very related: When it is known that something is wrong with language 
detection I suggest a better handling of the situation, in the other issue the configuration entry related to 
language detection was wrong which it should not be in the first place.
@cd: issue 110102 is probably yours as well
Comment 3 Rainer Bielefeld 2010-04-13 15:14:04 UTC
I confirmed Issue 110102 because I saw the mentioned error message when I tried
to start m76, but I believe this one is closer to the core of my problem.

I upgraded from  "Ooo-Dev 3.2.1 multilingual version English UI WIN XP:
[OOO300m14 (Build 9489)]" with a special detail: I unselected all modules except
WRITER during custom installation. I don't know whether that detail is important.

The way how and from what situation the update has been done might be the reason
for the problem. I uninstalled my damaged m76 and then did a second attempt to
install m76 (this time a complete installation) - now it works.
Comment 4 discoleo 2010-06-03 20:42:51 UTC
I have this problem again with m80. The previous solution (with bootstrap.ini)
does not work amnymore - see issue 110102 for further comments. That one is a P1
for me.
Comment 5 Rainer Bielefeld 2010-06-04 05:20:57 UTC
Reproducible with "Ooo-Dev 3.3 multilingual version English UI WIN XP:
[DEV300m80 (Build 9507)]. I upgraded from "Ooo-Dev 3.2.1 multilingual version
English UI WIN XP: [OOO320m16 (Build 9497)]" with various steps (m78 and m79 did
not work for me) and deleting user profile.
Comment 6 Olaf Felka 2010-06-04 07:13:56 UTC
*** Issue 112103 has been marked as a duplicate of this issue. ***
Comment 7 carsten.driesner 2010-06-04 10:12:09 UTC
cd: I would be nice if anyone can provide a step-by-step description on how to
reproduce this issue. I wasn't able to reproduce it on Windows Vista/XP/2000.
This would help me to fix this issue as soon as possible.

cd: As this issue is severe it must be fixed for OOo 3.3 (set target and state
to started/accepted).
Comment 8 Rainer Bielefeld 2010-06-04 10:35:08 UTC
Please excuse me, I wanted to write: NOT reproducible with "Ooo-Dev ...
Comment 9 discoleo 2010-06-04 12:35:51 UTC
I am installing OOo as always:
1. start OOo installer (dev80 in this case)
2. select Custom install
3. left all settings as is (selected only custom to check that everything is
fine, as I do have some unorthodox directories)
 Everything progresses as expected. [Java v20 was also installed the first time
I installed dev80 - it wasn't installed afterward anymore - I hope it is not
related to this install.]

As mentioned in another issue:
App data is on the C drive, while the program is installed on the L drive. If
needed, I can send you (in the evening today) various ini files per mail -
please specify which ones.

Reinstalling did not solve the issue. I did not check if deleting all the
previous directories will solve the issue - I only noticed afterward that  older
directories are still lurking on my computer.

I do not have a stable release installed either. Some errors may be related to
the fact that I do not have a stable release installed (and therefore NOT
reproducible if the stable release is still installed on the computer). I
believe this was one issue for the java-errors (I received on previous installs
often an error related to java - and I now believe that that error was related
to uninstalling the stable release).
Comment 10 thorsten.ziehm 2010-06-08 09:21:28 UTC
I could reproduce it on some Windows machines (both Windows XP).

What I did :
- had an old installation of OOo (e.g. OOo 3.2.1) with an old configuration
(updated for a long time)
- I think I had also a language pack installed (german) (but I do not know exactly) 
- I installed the m80 en-us
=> the first start results in this error
- when I delete my configuration I can start m80

In the configuration files I could find only, that en-us was activated
(setup.xcu). But I do not know, if this is updated by the installation of new
If it is needed I can send you my configuration files to reproduce this error.
Comment 11 carsten.driesner 2010-06-16 12:21:11 UTC
cd: After some investigation there is a strong hint that the start up problem is
related to a installed weblog-publisher extension. So could people who can
reproduce this problem confirm this?
Comment 12 joachim.lingner 2010-06-16 12:38:08 UTC
It's the weblog publisher. This is a duplicate of 162567 (internal oracle issue)
which is fixed on jl152. There is an error in the xcu which makes the config
manager struggle. I propose to close this issue. 
Comment 13 Stephan Bergmann 2010-06-17 10:36:14 UTC
@jl:  CWS jl152 changes the weblog publisher to no longer contain invalid .xcu
data, but that does not help for users updating to OOo 3.3 with an already
installed, old weblog publisher.

Hence, I will change the configmgr code to accept and ignore the invalid .xcu
data (as did the old pre-DEV300_m74 configmgr code).
Comment 14 Stephan Bergmann 2010-06-17 10:53:54 UTC
Comment 15 Stephan Bergmann 2010-06-17 15:32:53 UTC
fixed as <>
Comment 16 Stephan Bergmann 2010-06-22 13:24:12 UTC
@hi: please verify
Comment 17 h.ilter 2010-06-23 11:04:56 UTC
@OF: This is more your area. Please take over, Thanks.
Comment 18 Olaf Felka 2010-06-23 13:37:18 UTC
OF: What I've done:
- I've installed OOO320_m18
- I've installed blogger extension version 1.1.1 (the released on)
- I've updated the installation with cws jl153
- Office refuses to start with the given error message.
Comment 19 joachim.lingner 2010-06-23 15:54:45 UTC
Comment 20 Olaf Felka 2010-06-24 10:21:03 UTC
of: Fix verified in cws jl153.
Comment 21 rene 2010-07-06 10:18:05 UTC
how was this verified? I still have that error on my m83 + the patch which went
into jl153...
Comment 22 Olaf Felka 2010-07-06 11:09:08 UTC
Just read:
"OF: What I've done:
- I've installed OOO320_m18
- I've installed blogger extension version 1.1.1 (the released on)
- I've updated the installation with cws jl153
- Office refuses to start with the given error message."
Comment 23 rene 2010-07-06 12:09:54 UTC
and you really consider "- Office refuses to start with the given error
message." the fix? please don't tell me this is true. If you don't, why is this
Comment 24 Olaf Felka 2010-07-06 12:20:26 UTC
You're right. That's rubbish. I've been able to start the office with the given
test steps.
Comment 25 rene 2010-07-06 13:03:25 UTC
Nevermind, my error apparently was caused by our packging (which
worked in 3.2.1). Need to find out what changed in 3.3 which broke it....
Comment 26 rene 2010-07-06 14:21:19 UTC
(for the record: empty {UI,Setup}-brand.xcu. They don't exist anymore, and
having the empty there seems to break OOo. Of course noone told about such changes).
Comment 27 Stephan Bergmann 2010-07-06 14:34:25 UTC
(@rene, "Of course noone [sic] told about such changes": see
Comment 28 rene 2010-07-06 14:47:58 UTC
as if packagers are required to read interface-announce... I'd have expected
something like that on an appropriate dev@ list... But OK.. Besides that this
mail is too unverbose to know what you need to have to change. But anyways.