Issue 110846 - Blue background in notes view
Summary: Blue background in notes view
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: DEV300m76
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: wolframgarten
QA Contact: issues@graphics
URL:
Keywords:
: 112113 112255 (view as issue list)
Depends on:
Blocks:
 
Reported: 2010-04-13 14:13 UTC by wolframgarten
Modified: 2010-06-22 07:40 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description wolframgarten 2010-04-13 14:13:54 UTC
* Switching a new document into notes view on linux shows a light blue
background of the page
Comment 1 Armin Le Grand 2010-04-14 16:22:47 UTC
AW: Reproduced. Added to CWS aw081. Main reason will be that SdrPageProperties
for MasterPages get no XFillStyleItem(XFILL_NONE) set since they rely on a
StyleSheet for the MasterPage being set. I might remember that exactly the
Notes-View MasterPage does not fit into that scheme by not having a StyleSheet.
Taking a look...
Comment 2 Armin Le Grand 2010-04-15 10:22:12 UTC
AW: Indeed, that's the reason. Discussed with CL, it is no option to change the
model data to represent the needed state; whis would lead to problems when
saving/loading these. Thinking about a possibility to completely solve this by
model interpretation (adding exceptions, of course).
AW: Added exception to
ViewContactOfMasterPage::createViewIndependentPrimitive2DSequence and to
ViewContactOfMasterPageDescriptor::createViewIndependentPrimitive2DSequence, the
cases where the background visualisations get prepared. At least it is isolated
in the right places. Removed and replaced getCorrectFillAttributes, was used in
a single place anyways.
Checked, works. Committing...
Comment 3 Armin Le Grand 2010-04-15 10:29:54 UTC
AW: Checked in, done.
Comment 4 Armin Le Grand 2010-05-28 11:35:02 UTC
AW: Checked in CWS aw081, works as expected.
AW->WG: Please verify.
Comment 5 wolframgarten 2010-06-02 09:59:59 UTC
Verified in CWS.
Comment 6 Armin Le Grand 2010-06-04 13:55:32 UTC
*** Issue 112113 has been marked as a duplicate of this issue. ***
Comment 7 wolframgarten 2010-06-10 08:13:34 UTC
*** Issue 112255 has been marked as a duplicate of this issue. ***
Comment 8 Joe Smith 2010-06-21 21:36:47 UTC
Testing "OOo-dev 3.3  300m83(Build:9511)" on Fedora Linux 13

Printed notes have no blue background now.

Thanks!
Comment 9 wolframgarten 2010-06-22 07:40:09 UTC
Closed.