Issue 110918 - Default formula color gray
Summary: Default formula color gray
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Math
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: Unknown All
: P4 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-15 17:32 UTC by mahfiaz
Modified: 2011-03-10 10:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Text color to red (244.98 KB, image/jpeg)
2010-05-03 16:31 UTC, mahfiaz
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mahfiaz 2010-04-15 17:32:10 UTC
By default all formulas are shown, exported and printed using gray, which is
RGB(50,50,50).

1. On print this gives *ugly* results, because gray colors are made using raster.
2. This diminishes contrast on screen.

This happens both on Ubuntu version of Openoffice (I know your feelings about
that one) *and* latest OOo-dev. It likely also affects Windows and all other builds.

There is an easy (but tedious) workaround, you can force black by "color black
{}", which fixes all the abovementioned problems.
Comment 1 michael.ruess 2010-04-16 08:10:13 UTC
Cannot confirm this using OOo 3.2 and DEV300m76 on WinXP and ubuntu.
Looks like the build from the ubuntu repository has different default settings
for application colors. Please use official OOo builds and delete all
configuration folders.
Comment 2 michael.ruess 2010-04-16 08:11:07 UTC
Closed. In the official builds of OOo the default color for formulas is BLACK.
Comment 3 mahfiaz 2010-04-19 01:29:26 UTC
You are right. It was caused by an extension, not by default settings. My
sincere apologies for the noise.
Comment 4 mahfiaz 2010-05-03 13:52:27 UTC
I found out that on document creation "Input box text" color is used for default
text color. If this is wanted behaviour is somewhat questionable, I suspect most
people would always want black text in documents, at least I do.

The corresponding bug report for not-black theme is at launchpad:
https://bugs.launchpad.net/ubuntu/+source/light-themes/+bug/574383
Comment 5 michael.ruess 2010-05-03 14:44:24 UTC
I do not understand what you mean by "Input box text". Could you please explain
in a few words?
Here, on my ubuntu and Windows the text of Math formula objects is black...
Comment 6 mahfiaz 2010-05-03 15:47:27 UTC
"Input text color" is UI term for gconf key
/desktop/gnome/interface/gtk_color_scheme, which contains text_color.
Comment 7 mahfiaz 2010-05-03 15:47:48 UTC
"Input box color" is gnome-appearance-properties UI term for gconf key
/desktop/gnome/interface/gtk_color_scheme, which contains text_color.
Comment 8 michael.ruess 2010-05-03 16:24:11 UTC
Do you experience the problem in OO formula editor or also in other OOo
applications?
Comment 9 mahfiaz 2010-05-03 16:31:09 UTC
Created attachment 69265 [details]
Text color to red
Comment 10 mahfiaz 2010-05-03 16:35:12 UTC
I added a little picture with contrasting color. And yes, this affects all
components of OO. What is special about formulas, is that once created formula
will store it's default color and AFAIK this cannot be changed from UI later.
Comment 11 michael.ruess 2011-03-10 10:14:28 UTC
I see now, but it is desired to have the text colored as set in the mentioned configuration. See also text will be colored then in gedit e.g.
OOo takes the settings from the system as every application should do in this case.
Comment 12 michael.ruess 2011-03-10 10:15:09 UTC
Closed, the behavior will not be changed here.