Issue 111295 - Text in characterfields is shown as "0"
Summary: Text in characterfields is shown as "0"
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOO320m16
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: 3.4.0
Assignee: marc.neumann
QA Contact: issues@dba
Keywords: oooqa
: 113881 114153 (view as issue list)
Depends on:
Reported: 2010-04-30 19:14 UTC by robbygro
Modified: 2017-05-20 10:32 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Only "0" is shown in the character-fileds of the form (14.16 KB, application/vnd.sun.xml.base)
2010-04-30 19:15 UTC, robbygro
no flags Details
Same problem, now in OOo 3.1.1, not in OOO320m16 (10.12 KB, application/vnd.sun.xml.base)
2010-05-01 19:40 UTC, robbygro
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description robbygro 2010-04-30 19:14:38 UTC
I have installed OOo320m16 in as a user in my linux-system (without JRE). When I
open the form of the attached database (database is an example for another in the fields were no
names, only the values "0". I tried another form with the wizard - the same problem.
Comment 1 robbygro 2010-04-30 19:15:49 UTC
Created attachment 69207 [details]
Only "0" is shown in the character-fileds of the form
Comment 2 r4zoli 2010-05-01 10:26:44 UTC
In tested with OOo 3.2, OOO320m16 and DEV300m76 on win7, forms works same as you
The culprit in the underlaying "Name" table VARCHAR field formatted half text,
half number. 
If I open table in edit mode, the "Vorname" Format code contain "0" not "@", if
I add new field, it is formatted correctly, and works with forms.
New table works without problem.

Change your fields, or create new tables. 
Comment 3 r4zoli 2010-05-01 10:27:15 UTC
Comment 4 robbygro 2010-05-01 11:54:30 UTC
I have designed the tables under OOo 3.1.1. The fields "Vorname" and "Nachname"
are both varchar 50 and formatted with @. When I open the attachment in OOo
3.1.1 I see nothing formatted as "0".
Comment 5 Frank Schönheit 2010-05-01 17:21:46 UTC
I see the "0" in both 3.1.1 and 3.2 (which is a bug, also described in issue

Essentially, the document is broken, and we need to add a workaround for fixing
them while reading. Still, I am clueless on a) how the document broke and b) why
people continue to say they don't see the problem in 3.1.1.

Can you please describe as exactle as possible *which* 3.1.1. version you use?
Which platform? From, or some other flavour from some other
Comment 6 robbygro 2010-05-01 18:40:09 UTC
I have downloaded my attachment form friday. It works correct with my system.
The fields are varchar, the format "@". The form shows the text of the fields.
My OpenOffice Version: 3.1.1 (OOO310m19 Build 9421) in the original version from on a SuSE 11.2-system.
Comment 7 robbygro 2010-05-01 19:40:53 UTC
Created attachment 69230 [details]
Same problem, now in OOo 3.1.1, not in OOO320m16
Comment 8 robbygro 2010-05-01 19:48:29 UTC
I have added a new attachment. First I tried to reproduce the way of the first
database. I designed a part of a table in 3.1.1 and the form, saved the data and
closed 3.1.1. Opened the *.odb-file with OOo320m16, added a table and added a
field in the first table. All was OK in OOo320m16. Closing OOo320m16, changing
to the other user-account and opening: No text any more in the form, only "0"
and in the table also "0".
Comment 9 r4zoli 2010-07-27 15:13:26 UTC
I found one good workaround on forum:

- Open table for edit
- Change data type from [Text]VARCHAR to [Text]VARCHAR_IGNORECASE 
(the format changes from 0 to @)
- Change back to [Text]VARCHAR
- Save changes 
- Close table edit window

Then you can use form.
I tested on win7 with OOo 3.2.1.
Comment 10 r4zoli 2010-08-16 07:18:05 UTC
*** Issue 113881 has been marked as a duplicate of this issue. ***
Comment 11 r4zoli 2010-08-16 07:21:05 UTC
confirmed set to new
Comment 12 Frank Schönheit 2010-08-27 14:54:53 UTC
while it is still unclear to me how this numeric format slipped in for a text
column, I committed a fix to CWS dba34a, which will properly recognize this, and
not attempt to format string columns using a numeric format.
Comment 13 Frank Schönheit 2010-08-27 14:55:26 UTC
grabbing and targeting
Comment 14 r4zoli 2010-08-28 07:03:41 UTC
*** Issue 114153 has been marked as a duplicate of this issue. ***
Comment 15 Frank Schönheit 2010-09-29 09:32:50 UTC
fs->msc: please verify in CWS dba34a
Comment 16 marc.neumann 2010-11-03 10:35:31 UTC
verified in CWS dba34a

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System: