Issue 111358 - Extra characters appended in the generated URL when Inserting hyperlink from web content.
Summary: Extra characters appended in the generated URL when Inserting hyperlink from ...
Status: CLOSED DUPLICATE of issue 19690
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 3.2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-04 10:48 UTC by yfjiang
Modified: 2010-05-08 14:00 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description yfjiang 2010-05-04 10:48:16 UTC
[Steps]
  
    1. Launch OOo writer

    2. From Menu select Insert->Hyperlink

    3. Switch to 'Internet' Tab

    4. Check on the 'Web' box

    5. Fill up the 'Target' field with:
       
       http://en.opensuse.org/Bugs:OOo

    6. Click the round Button on the rightside of the 'Target' field, which is
    'Target in  Document'

    7. Wait for minutes to let OOo finish retrieving the website

    8. In the popped up 'Target in Document' dialog box, double click
    Headings->Contents

    9. Watch the 'Target' field
    
[Problem]

    The 'Target' field is then appended with:

        #Contents|outline

    The '|outline' tailed is redundant and lead the link failing to work.
Comment 1 yfjiang 2010-05-04 11:07:59 UTC
In addition, actually, OOo appended improper '|xxx' for other elements as well,
such as:

http://URL#TextFrames|frame
http://URL#Graphics|graphic
http://URL#Sections|region
Comment 2 eric.savary 2010-05-08 14:00:36 UTC
Roughly said, this is due to the fact that you can do more with hyperlinks
inside of a Writer document than what is allowed in HTML.
In the same time, the dialog cannot know if you intend to refer to an HTML
document or inside of Writer.

Explanation: in HTML the "#" as target inside of the page refers to named anchor
using "name" or "title". Inside of OOo, objects which in the HTML code might not
have a name will get one automatically (Tables, Graphics, here the "Contents"
which is a heading...).
Thus such references like target of type "outline" with name "Contents" work
only in Writer.

Furthermore: both URL forms
http://en.opensuse.org/Bugs:OOo#Contents|outline
http://en.opensuse.org/Bugs:OOo#Contents

Can only target to:
http://en.opensuse.org/Bugs:OOo

because there is, in this HTML page, no #Contents but just a text formatted as
heading 2 which has neither a name nor a title.

So this is a WONTFIX or at lieast a duplicate of issue 19690.

*** This issue has been marked as a duplicate of 19690 ***
Comment 3 eric.savary 2010-05-08 14:00:58 UTC
Closed