Issue 111583 - sw: Error: redline table corrupted: overlapping redlines
Summary: sw: Error: redline table corrupted: overlapping redlines
Status: CLOSED DUPLICATE of issue 110241
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: DEV300m76
Hardware: Unknown Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: mst.ooo
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-13 19:29 UTC by 400guy
Modified: 2010-05-21 22:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
backtrace (17.96 KB, text/plain)
2010-05-13 19:30 UTC, 400guy
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description 400guy 2010-05-13 19:29:15 UTC
Assertion failure.  To Reproduce ...

Google for [ keyboard mapping jaunty site:ubuntu.com ].  Select the
results from "AppleKeyboard" to the link "Cached" for the last result
on the page and copy this to the clipboard.

In OO, open a new writer document.

Paste from the clipboard.

From menu, select Edit > Changes.  Observe that Show is checked.

Click Record.

Ctrl-Home.

Move cursor after link "Similar" for the first ghit.

Type Enter.  Observe change bar on the line where the cursor was and
on the new line.

Type "a".  Program displays the "a" coloured as a change and
underscored as a link.

Type Shift-left.  Program shows the "a" selected.

In toolbar, click icon for underline.  Program displays Debug Output ...

    Error: redline table corrupted: overlapping redlines
    From File /home/terry/OOo_hacking/DEV300_m76/sw/source/core/doc/docredln.cxx
at Line 132
    Abort ? (Yes=abort / No=ignore / Cancel=core dump)


I am running a somewhat hacked non-product build of DEV300_m76.  My
local hacks are still as described in
<http://www.openoffice.org/nonav/issues/showattachment.cgi/69373/fudges>.


I shall soon attach a gdb log file with backtrace (sorry for the false
start) and the value of some variables.
Comment 1 400guy 2010-05-13 19:30:54 UTC
Created attachment 69450 [details]
backtrace
Comment 2 mst.ooo 2010-05-14 13:54:59 UTC
.
Comment 3 mst.ooo 2010-05-14 13:58:58 UTC
please try to narrow down the problem a bit more.
in this case it could be as simple as:

1. turn on changes->show, changes->record
2. insert some text
3. select inserted text
4. click on any format option, like underline
5. assertion

but this is indeed a serious problem, so thanks for reporting it.
fortunately, i've already fixed it.

*** This issue has been marked as a duplicate of 110241 ***
Comment 4 mst.ooo 2010-05-14 14:00:18 UTC
.
Comment 5 400guy 2010-05-21 22:21:40 UTC
Yes, mst.  I tried the steps suggested in your comment from May 14, and the
assertion came up right away.

( And I am trying to remember to include statuses VERIFIED and CLOSED when I
query the issues database. )