Issue 111636 - The background become no color to white color
Summary: The background become no color to white color
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: code (show other issues)
Version: OOO320m17
Hardware: All All
: P2 Trivial (vote)
Target Milestone: OOo 3.2.1
Assignee: marc.neumann
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-16 10:10 UTC by mtaki_goodday
Modified: 2017-05-20 10:24 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
screenshot (99.61 KB, image/png)
2010-05-16 10:11 UTC, mtaki_goodday
no flags Details
sample file (67.61 KB, application/vnd.oasis.opendocument.presentation)
2010-05-16 10:11 UTC, mtaki_goodday
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mtaki_goodday 2010-05-16 10:10:22 UTC
The background become no color to white color when I test with TCM No.109173 
with default template in OOo.
It does not reproduce on OOo3.1.1/3.2.0 just on OOo320m17.

How to reproduce this issue:
1. Open the sample file.
2. Copy the slide.
3. Paste the slide.
 The background become no color to white color.
Comment 1 mtaki_goodday 2010-05-16 10:11:13 UTC
Created attachment 69470 [details]
screenshot
Comment 2 mtaki_goodday 2010-05-16 10:11:52 UTC
Created attachment 69471 [details]
sample file
Comment 3 wolframgarten 2010-05-17 07:57:15 UTC
Reproducible in DEV300m77 and OOO320m17. Reassigned.
Comment 4 mdxonefour 2010-05-17 09:14:01 UTC
What so special with the text box in the sample? I can't reproduce it with a new
created document.
Comment 5 mtaki_goodday 2010-05-17 10:18:44 UTC
Additional information:

 It can reproduce if use [Title,Text] layout.
 It does not reproduce if use other layout.

1. Create new blank document.
2. Select [Title,Text] layout
3. Copy the slide.
4. Paste the slide.
 The background become none to fill [blue 8].
Comment 6 Marcus 2010-05-17 10:20:26 UTC
not reproducible when you use "Insert - Duplicate Slide" instead of copy & paste
Comment 7 grakic 2010-05-17 10:38:35 UTC
It is enough to copy just a text frame.

It looks like it is the error in styles hierarchy when copy is made. The 
original text frame has presentation:pr2 style with draw:fill-color="#ffffff", 
extended from presentation:prs-strategy-outline1 which set draw:fill="none".

When a copy of the frame is made it ends with a new style named graphic:gr1 (I 
guess becouse it is not an outline object anymore) which extends from 
graphic:standard style! graphic:standard has draw:fill="solid" and the text 
frame background becomes white.

If a new style can not extend presentation:prs-strategy-outline1 it should 
include its content into new graphic:gr1 so draw:fill stays at none.
Comment 8 groucho266 2010-05-17 15:46:29 UTC
The fix for issue 109515 seems to be the reason for this bug.  Undoing the SVX
part of the change makes the bug go away.

Now I have to figure out how to fix both bugs at the same time.
Comment 9 groucho266 2010-05-17 15:47:24 UTC
CCed: aw
Comment 10 mdxonefour 2010-05-18 13:28:41 UTC
adjusting target and prio
Comment 11 mdxonefour 2010-05-18 13:29:26 UTC
.
Comment 12 groucho266 2010-05-18 14:01:01 UTC
Issue 109515 fixes a crash caused by styles, copied and pasted from one document
to another, still reference the old model.  When that is destroyed the pointers
point into the wild: crash.

This was fixed by always replacing the copied styles with the default style of
the new model.  This lead to the white background as described above.

I changed this fix to first look up a style in the new document that has the
same name as the style of the old document.  If that does not exist the default
style is used as fall back.
Comment 13 groucho266 2010-05-19 12:19:27 UTC
@msc: Please verify.
Comment 14 marc.neumann 2010-05-19 13:35:32 UTC
verified in cws sdk321. Also the issue 109515 does not reappear