Issue 112461 - Freezing when opening presentations made with Office Powerpoint 2007
Summary: Freezing when opening presentations made with Office Powerpoint 2007
Alias: None
Product: Impress
Classification: Application
Component: open-import (show other issues)
Version: OOO320m12
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo
Depends on:
Reported: 2010-06-17 07:12 UTC by devindunseith
Modified: 2013-07-30 02:37 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description devindunseith 2010-06-17 07:12:19 UTC
When I open presentations that my colleague made on Office Powerpoint 2007, 
usually containing large images, Open Office Impress freezes within ~5 seconds 
every time. I have used an online converter to convert the .pptx file to .ppt 
and .odp, but it still freezes. I can create presentations and open/edit 
presentations made using Impress, but not those made in Office 2007. I have 
scoured the forums, but noone seems to have had this problem, and most advice 
for converting .pptx files (which I can not upload to google docs, my 
replacement for OOO when it freezes) is to open it with OOO Impress and save it.

I am running Ubuntu 10.04 (Lucid Lynx) with all latest upgrades on an Acer 
Aspire 4810T laptop.
Comment 1 Joe McConda 2012-06-09 17:50:33 UTC
I replicated the bug twice when I opened two seperate power point presentations. One was made on Office 2007, and the other was made on Office 2010. These are the steps that I followed:

1. Open the program 3.4
2. Click on "Presentation" tab
3. Click on "Open existing presentation"
4. Click on "Open..." tab which opened my downloads file
5. Clicked on file named "PowerPointViewer" and opened it, which opened "ASII Filter" window.
6. Settings were: 
     Character Set: Western Europe (Windows 1252/WinLat 1)
     Default Fonts: Times New Roman
     Language: English(USA)
     Paragraph Break: CR & LF
   Clicked "OK" tab

Within 5 seconds the Windows spinning circle cursor appeared and the program did nothing. A message appeared that said "Program not responding".

I closed the program and followed the same steps two more times, getting the same result. I then tried again the same way except I changed the "Character Set" setting to "Western Europe(ASCII US)"  and then to "Western Europe(DOS/OS2-437/US)". The program froze again on both settings. I tried these settings because the powerpoint presentations were made in the USA.

The problem must not be limited to Windows 2007, but includes Windows 2010 as well.

I am running Windows 7 on an ASUS laptop.
Comment 2 louqle 2012-09-14 02:07:19 UTC
could you please provide a sample file for this?
Comment 3 Rob Weir 2013-02-02 02:57:01 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
Comment 4 Johanna 2013-06-09 15:35:16 UTC
Johanna Forsberg 09/06/14

I tried to produce this bug and I can't. I can open a presentation that is made in Office 2007 and one that was made on Office 2010. 
I am running on windows 7. I am not on a laptop though, I am on a pc. 
I tried different builds (old - (2010) and new (2013) and I can't get the bug to happen and I do not know what builds the previous person tried.
Comment 5 Rob Weir 2013-07-30 02:37:35 UTC
Reset assignee on issues not touched by assignee in more than 1000 days.