Issue 112601 - Bitmaps in the background of master page not visible in slide show
Summary: Bitmaps in the background of master page not visible in slide show
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: ui (show other issues)
Version: DEV300m82
Hardware: All All
: P2 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: wolframgarten
QA Contact: issues@graphics
URL:
Keywords: regression
: 111121 112650 (view as issue list)
Depends on:
Blocks:
 
Reported: 2010-06-22 14:17 UTC by wolframgarten
Modified: 2017-05-20 10:22 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Patch to fix the main task (5.92 KB, text/plain)
2010-06-23 11:25 UTC, Armin Le Grand
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description wolframgarten 2010-06-22 14:17:40 UTC
Put a bitmap into the background of the master page. It is not visible in slide
show mode.
Comment 1 Armin Le Grand 2010-06-22 14:28:56 UTC
AW: Not working in DEV300m80.
AW: Not working in DEV300m78.
AW: Not working in DEV300m76.
AW: Seems not to work for a while (which is frightening). Who is guessing i
caused it, BTW...?
AW: Looking for even older versions...
Comment 2 wolframgarten 2010-06-22 14:31:50 UTC
The clue came from cl.. ;-)
Comment 3 Armin Le Grand 2010-06-22 14:34:05 UTC
AW: Works in DEV300m75 unxlngi6.pro. CWS aw079 was integrated in DEV300m76, so
it may have to do with #i99386#, the MPBGO removal. It will depend in which way
the Slideshow retrieves the graphical data for the background. Need to ask AF...
Comment 4 Joost Andrae 2010-06-22 15:00:52 UTC
added keyword
Comment 5 Armin Le Grand 2010-06-22 16:04:25 UTC
AW: Has nothing to do with bitmaps, is a general problem with page FillStyles.
The UNOGraphicExporter gets the background from the given page which is not the
masterpage. It creates a temporary SdrObject with it to stay compatible with the
old MPBGO. The SdrPageProperties from that page get used directly which have a
fillstyle of XFILL_NONE.
The error is the direct usage of SdrPageProperties from that page; if it has a
MasterPage and fillstyle is XFILLSTYLE_NONE, use the fill attributes from the
Masterpage (also take a look that SdrPageProperties from MaterPage HAS a
StyleSheet, else the pool default blue8 will be used).
That error does not happen when modifying the PageStyle interactively, looks
like the SdrPageProperties from the SdrPage get set directly, too.
Comment 6 Armin Le Grand 2010-06-22 17:26:24 UTC
AW: Problem is indeed that the temporary shape got not the right SfxItemSet from
the right page. Added getCorrectSdrPageProperties() to SdrPage and
MasterPageDescriptor to not have the code double somewhere; adapted usages in
GraphicExporter and ViewContactOfMasterPageDescriptor.
AW: Unfortunately, this was not enough yet. When the MasterPage has the
SfxItemSet, there are NO items set, but a StyleSheet keeps the needed
information. Also added setting the needed StyleSheet at the temporary object.

AW: Looking now for all places using getSdrPageProperties() to set the items
there; there seems to be an error there, too...
Comment 7 Armin Le Grand 2010-06-23 10:36:39 UTC
AW: Indeed, in fupage.cxx (sd) in FuPage::ApplyItemSet at the end, the
attributes get set for the page directly even when set to all is choosen. I
think this should happen at the end of FuPage::ExecuteDialog (where all other
itemset changes are applied and it is known what to do). Have to ask SD'lers to
make sure...
Comment 8 Armin Le Grand 2010-06-23 11:25:07 UTC
Created attachment 70170 [details]
Patch to fix the main task
Comment 9 Armin Le Grand 2010-06-23 11:26:45 UTC
AW: Added patch to fix the visualisation.
AW->CL: Please take over and take a look why attributes are set at the single
page when 'apply to all' is used (sd/source/ui/func/fupage.cxx ln 590).
Comment 10 wolframgarten 2010-06-24 12:28:23 UTC
*** Issue 112650 has been marked as a duplicate of this issue. ***
Comment 11 clippka 2010-06-29 16:53:32 UTC
fixed in cws impress193
Comment 12 clippka 2010-07-06 16:41:42 UTC
verified in cws, back to qa
Comment 13 wolframgarten 2010-07-07 13:11:36 UTC
Verified in CWS.
Comment 14 groucho266 2010-07-07 16:11:38 UTC
*** Issue 111121 has been marked as a duplicate of this issue. ***