Issue 112648 - Password-protected ODS accepts password but fails to open
Summary: Password-protected ODS accepts password but fails to open
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOO320m12
Hardware: Other Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2010-06-24 10:30 UTC by peterjmous1
Modified: 2017-05-20 11:35 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description peterjmous1 2010-06-24 10:30:46 UTC
A couple of hours ago I opened a password-protected spreadsheet in Calc, made
some edits, and saved without problems. I just tried to re-open the file, it
accepts my password and it starts loading, but then it gives following error
message: "Read-Error. The wrong password has been entered."

This cannot be due to mistyping of the password, because if I intentionally
mis-type the password I get a different message: "The password is incorrect. The
document cannot be opened.". Furthermore, the message displays before the file
loads, whereas with the correct password the error message displays after the
loading bar at the bottom of the screen has filled up.

On the OpenOffice community forum I found a related problem that was solved
(viewtopic.php?f=9&t=10401&start=0#p48747), but the solved problem relates to a
corrupt file that cannot be opened after a crash and subsequent recovery
process. The solution was to use a hex editor to remove "manifest.xmlPK" at the
end of the file. I tried that but it did not resolve my problem.

I maintain the file on a laptop running Windows XP, but I have the same problem
on my netbook, which runs OpenOffice 3.1 on Ubuntu.
Comment 1 peterjmous1 2010-06-25 02:09:21 UTC
Just tried opening the document in Lotus Symphony, and the same problem occurs:
 the password is accepted, but after loading there is an error message "An error
occurred while loading this document.  The password was entered incorrectly or
the process was canceled.".
Comment 2 jbf.faure 2010-06-26 08:00:39 UTC
Same problem has been reported to me (contact email on fr website) for OOo 3.2
on MacOS  10.6.4.

Regards. JBF
Comment 3 frank 2010-07-20 10:28:01 UTC
Hi Mikhail,

please take over as discussed.

Comment 4 Marcus 2017-05-20 11:35:17 UTC
Reset assigne to the default "".