Issue 112691 - Hebrew text is exported in reverse order to PPT format
Summary: Hebrew text is exported in reverse order to PPT format
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Impress
Classification: Application
Component: save-export (show other issues)
Version: OOO320m19
Hardware: Unknown All
: P2 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: graphicsneedsconfirm
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-25 13:18 UTC by kaplanlior
Modified: 2010-10-10 11:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
testcase odp file (11.26 KB, application/vnd.oasis.opendocument.presentation)
2010-06-25 13:29 UTC, kaplanlior
no flags Details
openoffice screenshot - correct (68.54 KB, image/png)
2010-06-25 13:30 UTC, kaplanlior
no flags Details
screnshot powerpoint - wrong order (76.46 KB, image/png)
2010-06-25 13:31 UTC, kaplanlior
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kaplanlior 2010-06-25 13:18:13 UTC
I created a presentation in Hebrew and found out that when saving it to PPT
format the words order appear in reverse order. When exporting to PDF the word
order is as expected.

If I write "string1 string2" I would get "string2 string1" in PPT (wrong order)
and "string1 string2" in PDF (correct order). The problem is the order of the
strings in the sentence, although each word has the letter in the correct order.
I'm mentioning this as Hebrew is RTL and the sentences are written from right to
left.

When opening the ppt file in oo.org, it looks OK, the problem is when viewing
the file in Power Point.

I've done some testing to figure out the scope of the problem. I used:
1. oo.org 3.2.1 on Debian (based on go-oo.org). version info: OOO320m19 (Build:9505)
2. oo.org 3.2.0 on windows Vista (based on oo.org release). version info:
OOO320m19 (Build:9505)

Setting the page format doesn't have any effect of the problem (tested with both
RTL and LTR). Same for paragraph directionality.

Way to reproduce:
1. open a new impress presentation.
2. select a layout for your slide (doesn't matter which one).
3. insert a few Hebrew strings (e.g. "מחרוזת1 מחרוזת2 מחרוזת3").
4. save as odp format (for reference).
5. export as PDF.
6. save as PPT format, and open in power point.

Expected result: 
The strings order is the same for all viewers (string1 is the right most and
string3 is the left most). Which is the same as the oo.org and PDF viewer show
the text.

Actual result: 
In power point the the string order is reversed, so string1 is the left most and
string3 is the right most. Which is different from the way oo.org the PDF viewer
shows the text.

I hope this could be fixed for 3.2.2 (if planed) or for 3.3.

Kaplan
Comment 1 kaplanlior 2010-06-25 13:29:36 UTC
Created attachment 70220 [details]
testcase odp file
Comment 2 kaplanlior 2010-06-25 13:30:45 UTC
Created attachment 70221 [details]
openoffice screenshot - correct
Comment 3 kaplanlior 2010-06-25 13:31:24 UTC
Created attachment 70222 [details]
screnshot powerpoint - wrong order
Comment 4 wolframgarten 2010-06-25 13:43:37 UTC
Reproducible with PPT 2003 but ok in PPT2007. So it is a PPT problem that is
fixed in the meantime...
Comment 5 wolframgarten 2010-06-25 13:44:17 UTC
Closed.
Comment 6 kaplanlior 2010-06-25 14:08:08 UTC
I'll try to get a PPT2007 to test it.

This might be a bug in PPT2003, but what about a work around? Think about a
situation that you take a PPT file, resave it after some changes, and now people
without oo.org can't work on the file.
Comment 7 micha_silver 2010-10-10 11:41:50 UTC
I also got bitten by this bug. Can anyone verify that in MS Office 2007 
presentations created in OO.org Impress display hebrew correctly??
Thanks,
Micha