Issue 112694 - Thesaurus: crashes with new thesaurus dialog (non-pro builds only)
Summary: Thesaurus: crashes with new thesaurus dialog (non-pro builds only)
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: DEV300m83
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords:
: 114786 (view as issue list)
Depends on:
Blocks: 111112
  Show dependency tree
 
Reported: 2010-06-25 14:31 UTC by thomas.lange
Modified: 2017-05-20 11:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description thomas.lange 2010-06-25 14:31:12 UTC
E.g. in Writer
- in thesaurus dialog double click on one of the synonym entries (the non-bold
ones) in the alternatives control -> crash.

The call stack looks like this:
 	svtmi.dll!SvLBoxEntry::GetFirstItem(unsigned short nId=3)  Line 648 + 0xc
bytes	C++
 	svtmi.dll!SvTreeListBox::GetCheckButtonState(SvLBoxEntry * pEntry=0x1c61a0a8)
 Line 585 + 0xa bytes	C++
 	svxcoremi.dll!SvxCheckListBox::MouseButtonDown()  + 0xa9 bytes	C++
 	vclmi.dll!ImplHandleMouseEvent(Window * pWindow=0x0b2eae50, unsigned short
nSVEvent=1, unsigned char bMouseLeave=0, long nX=110, long nY=153, unsigned long
nMsgTime=1354375578, unsigned short nCode=1, unsigned short nMode=3)  Line 811	C++
 	vclmi.dll!ImplHandleSalMouseButtonDown(Window * pWindow=0x0b2eae50,
SalMouseEvent * pEvent=0x0186f280)  Line 2073 + 0x48 bytes	C++

This happens actually after the double click handler
(AlternativesDoubleClickHdl_Impl in cui/source/dialogs/thesdlg.cxx) has already
been successfully called.
Comment 1 thomas.lange 2010-06-25 14:33:03 UTC
TL->FS: please take over as discussed. Thanks!

(Note: I needed to split the original issue 112646 in two. The original issue
was already approved as showstopper by MD.)
Comment 2 Frank Schönheit 2010-09-01 20:56:08 UTC
fixed in CWS dba33i

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300/dba33i
Comment 3 Frank Schönheit 2010-09-08 06:50:56 UTC
fs->sba: please verify in CWS dba33i
Comment 4 stefan.baltzer 2010-09-08 11:38:38 UTC
SBA->TL: Your issue :-)
Please have a look
Comment 5 thomas.lange 2010-09-08 11:43:35 UTC
Works fine now. Thanks!
Comment 6 thomas.lange 2010-09-08 11:44:44 UTC
back to sba. For later verification and closing once it is in the master.
Comment 7 thomas.lange 2010-09-28 01:57:50 UTC
*** Issue 114786 has been marked as a duplicate of this issue. ***