Issue 112731 - Default font replacement for Calibri on Win XP.
Summary: Default font replacement for Calibri on Win XP.
Status: CLOSED FIXED
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOo 3.2.1
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: eric.savary
QA Contact: issues@gsl
URL:
Keywords:
Depends on: 110023
Blocks: 108974 111112
  Show dependency tree
 
Reported: 2010-06-27 14:19 UTC by eziomartello
Modified: 2017-05-20 10:22 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
I confirm 3.2.1 official version (163.22 KB, text/plain)
2010-06-29 11:11 UTC, eziomartello
no flags Details
Font gothici.tff (52.39 KB, text/plain)
2010-06-30 08:14 UTC, eziomartello
no flags Details
An other problematic font. (43.04 KB, text/plain)
2010-07-01 13:14 UTC, eziomartello
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description eziomartello 2010-06-27 14:19:38 UTC
If the font Calibri is not present in the system (e.g. Win XP), I propose a
default replacement with Arial. 

Now the replacement, in my system, is made with a gothic font.
Terrible.
Comment 1 vitriol 2010-06-27 17:46:57 UTC
Add me to CC.
Comment 2 Olaf Felka 2010-06-28 06:40:58 UTC
@ sba: 'font replacement': something for you?
Comment 3 hdu@apache.org 2010-06-29 06:11:24 UTC
http://hg.services.openoffice.org/DEV300/file/tip/officecfg/registry/data/org/openoffice/VCL.xcu
shows indeed that there is no explicit fallback known for Calibri on XP. The SansSerif-Attribute should 
have resulted in a fallback to a default-SansSerif font like Arial though.

Issue 110023 (fixed for OOo321 in CWS sw321bf01) could have resulted in the problem you saw, but only 
in Versions older than OOo321. Please confirm that the problem can be seen in the OOo 3.2.1 official 
release.
Comment 4 eziomartello 2010-06-29 11:11:48 UTC
Created attachment 70283 [details]
I confirm 3.2.1 official version
Comment 5 hdu@apache.org 2010-06-29 12:11:36 UTC
Interesting... Please provide a small bugdoc too. If the fontname was misspelled this could explain some 
of the trouble.
Comment 6 vitriol 2010-06-29 12:22:04 UTC
@udu: You can download the original document from this link:

http://www.calcioalpallone.com/wp-content/uploads/2010/02/calendario-mondiali-2010.xls
Comment 7 hdu@apache.org 2010-06-29 13:56:42 UTC
On my test-XP everything works as expected. Can anyone else reproduce the problem?
Other than that: Nice bugdoc... now we can plan better for the next two weeks ;-)
Comment 8 vitriol 2010-06-29 14:13:32 UTC
I can't reproduce, but I have Calibri installed on my only XP machine. It should
try without the font.
Comment 9 eziomartello 2010-06-29 17:12:44 UTC
An Italian OOo user wrote:
XP Pro SP3, OO.o aggiornatissimo, Calibri assente:

Caratteri gotici! 

I think that is comprehensible.
It is Italian language.
'Assente' is 'Not present'.
'Calibri assente' is 'Calibri not present'.
'Caratteri gotici' in English is 'Gothic Fonts'.

May be a localization problem?
Comment 10 eziomartello 2010-06-30 08:12:55 UTC
In my systhem the problem is present only whith gothici.tff font installed.
Comment 11 eziomartello 2010-06-30 08:14:11 UTC
Created attachment 70312 [details]
Font gothici.tff
Comment 12 hdu@apache.org 2010-06-30 08:55:48 UTC
Confirming. With this font installed it can be reproduced => analyzing
Comment 13 eziomartello 2010-07-01 13:14:57 UTC
Created attachment 70335 [details]
An other problematic font.
Comment 14 hdu@apache.org 2010-07-01 16:09:32 UTC
Fixed in CWS vcl113: the known fontsubst attributes are now used fully
Comment 15 tommy27 2010-07-01 19:45:18 UTC
I'm disappointed by target 3.4

I think It would be nice to see this fixed issue integrated in OOo 3.3
Comment 16 hdu@apache.org 2010-07-02 13:00:12 UTC
> It would be nice to see this fixed issue integrated in OOo 3.3

So would I, that's why I am lobbying for it with the release team:
http://www.openoffice.org/servlets/ReadMsg?list=releases&msgNo=15750
Comment 17 hdu@apache.org 2010-07-02 14:41:49 UTC
My changes in CWS vcl113 are now also transplanted into the OOo330 CWS ooo33gsl02
Comment 18 tommy27 2010-07-03 09:32:12 UTC
@hdu

well done
Comment 19 hdu@apache.org 2010-07-07 08:40:29 UTC
@es: please verify in CWS ooo33gsl02
Comment 20 hdu@apache.org 2010-07-07 09:48:41 UTC
.
Comment 21 eric.savary 2010-07-08 14:54:27 UTC
Verified in CWS ooo33gsl02