Issue 112758 - integration of renaissance2 in m81 broke smoketestoo_native
Summary: integration of renaissance2 in m81 broke smoketestoo_native
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: DEV300m81
Hardware: Unknown All
: P1 (highest) Trivial (vote)
Target Milestone: ---
Assignee: rene
QA Contact: issues@installation
Keywords: regression
Depends on:
Blocks: 112263
  Show dependency tree
Reported: 2010-06-28 14:28 UTC by rene
Modified: 2013-08-07 15:26 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

patch to change new introduced static BitmapEx to static pointer (4.44 KB, text/plain)
2010-06-28 16:39 UTC, clippka
no flags Details
better patch (5.54 KB, text/plain)
2010-06-29 14:17 UTC, clippka
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description rene 2010-06-28 14:28:29 UTC
as discussed on dev@tools:

--- snip ---
It worked fine between m77 and m80 (before m77, it requried X11), and           
broke on m81. hg bisect identified the integration of renaissance2 as           
the cws that broke it. 
--- snip ---

--- snip --
: &&                                                                            
/home/cl/build/compile/solver/300/ \              
-env:arg-user=./ \                              
Fontconfig error: Cannot load config file                                       
Fontconfig error: Cannot load config file                                       
# A fatal error has been detected by the Java Runtime Environment:              
#  SIGSEGV (0xb) at pc=0xb6133dec, pid=14438, tid=3030546128                    
# JRE version: 6.0_16-b01                                                       
# Java VM: Java HotSpot(TM) Client VM (14.2-b01 mixed mode linux-x86 )          
# Problematic frame:                                                            
# C  []                                                     
# An error report file with more information is saved as:                       
# /home/cl/build/compile/smoketestoo_native/hs_err_pid14438.log                 
# If you would like to submit a bug report, please visit:                       
[error occurred during error reporting , id 0xb]                                
120: 14438 Abgebrochen             "$sd_prog/$sd_binary" "$@"             
Test name: (anonymous namespace)::Test::test                                    
tearDown() failed                                                               
- equality assertion failed                                                     
- Expected:                                                                     
- Actual  :                                                                     
Failures !!!                                                                    
Run: 1   Failure total: 1   Failures: 1   Errors: 0                             
dmake:  Error code 1, while making 'cpptest'
--- snip---
I tried to track it down further back in time, and I must say that cws          
is a pain in the ass. Virtually no revision builds because of cyclic            
dependencies or typos. And even that, the history isn't clear to me.            
Apparently it merged in renaissance1, that is still open and being worked on.   
On top of that, smoketest on the earlier revisions reports success,             
but one can still see the segfault messge that is not there on the              
original Master.                                                                
I might have taken a wrong turn somewhere, but as written before that           
cws doesn't follow the commit-log scheme and doesn't add the cws name           
in the commit-message.                                                          
Anyway - my path took be back to changeset 5c75abeb21aa and that still          
exhibits the problem. This is based on m65 (way older than                      
renaissance2's "milestone created") - fails in the sense that building          
in smoketestoo_native does exit with status 0, but shows the                    
That revision is a 1295 line diff - and that's it for me....                 
--- snip ---       

seen so far on various buildbots, mandriva and Debian, redardless of what JDK
use (Sun/OpenJDK/...)
Comment 1 rene 2010-06-28 14:29:04 UTC
must be fixed ASAP, sometest vurrently is impossible
Comment 2 2010-06-28 15:15:40 UTC
is -> cl: If renaissance2 is the cause of this problem, this should be your task ;-)
Comment 3 clippka 2010-06-28 15:25:39 UTC
cl: the last snip from the discussions on dev@tools shows that the segfault is
also happening prior to renaissance2. Renaissance2 did not touch any platform
depended stuff concerning the smoketest.

cl->sb: as discussed, please have a look at why the office crash here
cl->rene: is it possible that you install an ooo version on a machine that fails
the smoketest and execute the smoketestoo_native/data/smoketestdoc.sxw by hand
and  note here which test actually fail, if any. or if there are other problems
while loading that document?
Comment 4 Stephan Bergmann 2010-06-28 15:42:19 UTC
@cl:  "the last snip from the discussions on dev@tools shows that the segfault is
also happening prior to renaissance2" -- no, it only shows that renaissance2
probably had a long and winding history  ;)

Apart from that, I just contacted cloph on dev@tools to find out what exactly is
broken here.
Comment 5 clippka 2010-06-28 16:39:05 UTC
Created attachment 70271 [details]
patch to change new introduced static BitmapEx to static pointer
Comment 6 clippka 2010-06-28 16:41:06 UTC
cl: since sb suspects newly introduced static BitmapEx members in sd module to
be the cause of the office crash on close, I attached a patch to replace those
with static pointers (a scheme which is already used elsewhere).

I applied this patch to cws impress193 and started mandriva buildbots for 32 and
64 bit to see if this changes anything
Comment 7 rene 2010-06-28 17:14:02 UTC
Hmm, at least here it seems to work with xvfb-run but fails with svp-plugin.
Maybe that helps to find the problem (your patch didn't change it)
Comment 8 lohmaier 2010-06-28 20:23:29 UTC
building impress193 (private cws - sigh) works for smoketestoo_native
(more precise: 0742a6ab67e1 built fine and smoketestoo_native succeeded as well.
(on the Mandriva x64 one, without X11))
Comment 9 Stephan Bergmann 2010-06-29 08:19:33 UTC
So, what is the status now?  The attached i112758_patch.txt solves the problem
for cloph, but still causes a SEGV during smoketestoo_native for rene (when not
using X11), right?

If so, rene, please make a complete build configured with --disable-strip-solver
(to have meaningful stack trace information) and "ulimit -c unlimited" (to
enable core files) and give me access to the stack trace information in the core
file resulting from the above SEGV.
Comment 10 2010-06-29 12:45:40 UTC
FWIW the patch solves the BitmapEx related crash at application exit for me too (on DEV300_m81).
Comment 11 clippka 2010-06-29 14:17:16 UTC
Created attachment 70294 [details]
better patch
Comment 12 clippka 2010-06-29 14:19:14 UTC
cl->obo: please use my second patch from today as a master fix, thank you
Comment 13 oliver.bolte 2010-06-29 14:33:34 UTC
Fixed in DEV300_m84 with revision: 85e7cfbbb08a
Comment 14 oliver.bolte 2010-07-15 14:01:50 UTC
@rene: verify, please.
Comment 15 rene 2010-07-18 18:11:51 UTC
I can confirm this ONLY for X11 (i.e. xvfb-run, but see below), NOT for using
svp. In the second case I still get:

: &&    
/home/rene/ \
-env:arg-user=./ \
./ -env:arg-doc=./
Test name: N12_GLOBAL__N_14TestE::test
setUp() failed
- equality assertion failed
- Expected: 2
- Actual  : 0

Test name: N12_GLOBAL__N_14TestE::test
tearDown() failed
- equality assertion failed
- Expected: 0
- Actual  : 77

Failures !!!
Run: 1   Failure total: 2   Failures: 2   Errors: 0
dmake:  Error code 1, while making 'cpptest'

though with no Java crash.

As many things outside of OOo using OOo use svp, I don't believe this is a good
sign ;)

(with xvfb-run it just "hangs", running under "normal" $DISPLAY says
"A general error occursed while accessing your central configuration").
Comment 16 rene 2010-07-18 19:14:39 UTC
filed as issue 113228
Comment 17 rene 2010-07-19 20:44:17 UTC
... which turned out to be INVALID.. My bad, sorry.

works in m1 for me on both "normal" $DISPLAY/xvfb-run and svp
Comment 18 rene 2010-07-19 20:44:36 UTC
close, as working in m1