Issue 112764 - OO wrongly claims that pps is encrypted
Summary: OO wrongly claims that pps is encrypted
Status: CONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.2.1
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL: http://www.margitos.hu/temp/Anglia_El...
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-28 16:02 UTC by tzp
Modified: 2013-02-21 19:17 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The problematic pps file (6.96 MB, application/vnd.ms-powerpoint)
2010-06-29 08:40 UTC, tzp
no flags Details
screenshot (4.21 KB, image/png)
2010-06-29 10:56 UTC, wolframgarten
no flags Details
PPT Slide Show opened (1.18 MB, text/plain)
2010-08-30 17:40 UTC, jaguilar2008
no flags Details
prompt on attempt to edit (2.25 MB, text/plain)
2010-08-30 17:41 UTC, jaguilar2008
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description tzp 2010-06-28 16:02:14 UTC
When downloading and opening the referred pps, OO 3.2.1 gives an error popup:

"Move background page assignment.
The loading of password-encrypted Microsoft PowerPoint presentations is not
supported."

This is erroneous, as the file is NOT encrypted, I could open it successfully
with MS powerpoint running in a Virtualbox.
Comment 1 jbf.faure 2010-06-29 05:22:25 UTC
changing wrong component to presentation.
Probably a duplicate of issue 46307.

Regards. JBF
Comment 2 tzp 2010-06-29 08:40:10 UTC
Created attachment 70279 [details]
The problematic pps file
Comment 3 wolframgarten 2010-06-29 10:56:19 UTC
Created attachment 70282 [details]
screenshot
Comment 4 wolframgarten 2010-06-29 10:57:29 UTC
Both, Powerpoint 2003 and Powerpoint 2007 ask for a password when trying to open
the file.
Comment 5 wolframgarten 2010-06-29 10:59:36 UTC
Closed.
Comment 6 tzp 2010-06-29 11:13:58 UTC
No, my powerpoint 2003 doesn't ask for a password, just shows the file.
Pls. reopen this.
Comment 7 wolframgarten 2010-06-29 11:46:15 UTC
If we cannot reproduce the problem we cannot fix anything. Did you have a try on
another 2003 PPT version? 
Comment 8 tzp 2010-06-30 13:38:27 UTC
Yes, I tried on another Powerpoint 2003 and it worked there too.
Comment 9 jaguilar2008 2010-08-30 17:39:51 UTC
Replicated issue successfully on MS PowerPoint 2010, the slide show opened 
(double-click the file) directly without any other options available. The slide
show is viewable only on MS PowerPoint; however, not editable. I tried opening
directly from PowerPoint in order to edit (opened MS PowerPoint, went to File -
Open) and it prompted for password. This .ppt is set for viewing only and
encrypted for editing, OOo 3.2 and 3.2.1 open this file as editable, since the
encryption is not supported by OOo, the .ppt is not opened. Are you able to edit
the powerpoint once you open it in Virtualbox? I ran MS PowerPoint in Windows as
I do not have a copy of Office 2003/07 right now, but the issue is in essence
the same; if anything I should have been able to edit (if you are able) as well
being Office native to Windows. Attached are screen shots of my replications.
Comment 10 jaguilar2008 2010-08-30 17:40:54 UTC
Created attachment 71482 [details]
PPT Slide Show opened
Comment 11 jaguilar2008 2010-08-30 17:41:24 UTC
Created attachment 71483 [details]
prompt on attempt to edit
Comment 12 Edwin Sharp 2013-02-21 19:17:26 UTC
The message in Rev. 1400866: "Read-Error. The loading of password-encrypted Microsoft PowerPoint presentations is not supported."

PowerPoint 2010 opens the attachment without a password.